Matomo-Backend plötzlich weitgehend leer, aber Matomo funktioniert weiterhin


#1

Hi!
Bei mir läuft Matomo schon seit etlichen Jahren. Auch jetzt arbeitet es stabil und mit Zertifikat / https-Verbindung, aber nicht auf der neuesten Matomo-Version.
Wöchentlich erhalte ich per eMail die Besucherstatistik aller meiner Websites. Über die MATOMO-App erhalte ich auf meinem Android-Smartphone auch die kompletten Auswertungen des Dahsboard angezeigt. Und auch die OptOut-Texte in den Websites werden einwandfrei angezeigt.
Folglich hatte ich erst wegen des Matomo-Updates Veranlassung, mal wieder über meinen Browser (Firefox 61.0.2) ins Backend zu schauen. Und da erlebte ich eine böse Überraschung:
Das Dashboard erscheint gar nicht mehr. Statt dessen sehe ich eine kleine graue Grafik “Loading Data”… bis in alle Ewigkeit.
Ich kann in die Administration wechseln und bekomme zwar die linke Menüleiste angezeigt. Aber nur einige Menüpunkte funktionieren. Zudem ist die Lade- / Reaktionszeit unglaublich lahm. Ich konnte auch die Diagnose / Systemseite aufrufen und anzeigen lassen. Dort wurden aber keine Fehler gemeldet.

In diesem Zustand kann ich auch über die integrierte Funktion kein Update durchführen. Vielelicht ist es auch nicht sinnvoll, in dem jetzigen Zustand ein Update zu installieren?

Übrigens: Beim LogIn steht unterhalb der eigentlichen LogIn-Felder das Angebot, neue Passwörter einzugeben. Davon möchte ich keinen Gebrauch machen, weil ich die dann auf den anderen Geräten ebenfalls ändern müsste. Meine Passworte sind 24 Zeichen lang und ich habe keinen Bedarf, diese zu ändern.
Besteht evtl. seitens Matomo ein Zwang dazu, die Passworte zu ändern und meine o.g. Probleme entstehen durch die Nichtänderung der Passworte?


(Lukas Winkler) #2

Hallo,

Das ist das Passwort-Vergessen Feature, welches normalerweise nur nach einem Klick auf “Password Vergessen” erscheint (siehe z.b. auf https://demo3.matomo.org/)

Aber es sieht sehr stark dannach aus, dass etwas in deinem Browser alles Javascript von der Matomo domain blockiert und dadurch der Großteil der Funktionen nicht ausgeführt werden können. Ich würde mal empfehlen Adblocker und Ähnliches im Matomo Backend zu deaktivieren. Vielleicht blockiert ja eine neue blocking-list matomo.* oder ähnliches.


#3

Danke dir Lukas!
Ich habe folgende Firefox-PlugIns / AddOns aktiv:
Canvas-Blocker, Cookie AutoDelete, Cookie Manager, HTTPS Everywhere, uBlock Origin und uMatrix.
Für das Matomo-Backend habe ich den Canvas-Blocker sowie uBlockOrigin und uMatrix deaktiviert. Das hat leider keinen Erfolg gebracht.
Ich hatte diese PlugIns schon länger in Benutzung - auch in der zeit, in der ich noch ab und zu ins Matomo-Backend hinein geschaut hatte. Es hatte nie Probleme gegeben.
Was tun?


(Lukas Winkler) #4

Hallo,

Dann öffne das Firefox-Entwicklertool auf der Matomo-Webseite (F12) und schau, ob Fehler auftreten (höchstwahrscheinlich) und ob im Netzwerktab Anfragen fehlschlagen.

Es könnte auch helfen, alles im Matomo /tmp/ Ordner zu löschen, damit alle Dateien neu generiert werden.


#5

Mit den Entwicklertools bin ich nicht so recht vertraut. Fehlermeldungen, die als soclhe gekennzeichnet wären, habe ich keine entdeckenkönnen und wüsste auch nicht, wo die zu finden wären.
Damit wir hier weiter kommen, habe ich mal zwei Screenshots gemacht, eine vom Seitenquelltext, der dem Browser geliefert wurde und eins von der Netzwerkübertragung. Vielleicht hilft das, um dem Problem auf die Spur zu kommen?


(Lukas Winkler) #6

Hallo,

Wenn du den “Konsole”-Tab öffnest, siehst du gleich die Fehler:

Dein Webserver sendet den folgenden HTTP-Header:

content-security-policy: default-src 'self'

CSP ist ein ziemlich komplexes Thema, aber vereinfacht gesagt, bedeutet default-src 'self' glaube ich, dass der Webbrowser kein Javascript ausführen darf, welches direkt im HTML steht (und noch vieles mehr)

Wegen des Headers verbietet der Browser somit die Ausführung von Javascript, welches Matomo benötigt.

Du kannst also nun einen ganz präzisen CSP-Header definieren, der die richtigen Funktionen für Matomo aktiviert (angeblich funktioniert Implement "Content Security Policy" (CSP) · Issue #1542 · matomo-org/matomo · GitHub), oder den Header entfernen.


#7

Mist! Ich hab gerade deinen zweiten Tipp ausprobiert und den Inhalt von tmp gelöscht. Jetzt komme ich gar nciht mehr in Matomo herein!

Ja ich habe in der htaccess folgende Header-Settings aktiviert:

Header set Content-Security-Policy “default-src ‘self’”

Header set X-Frame-Options “SAMEORIGIN”

Header always set X-Content-Type-Options “nosniff”
Header always set X-XSS-Protection “1; mode=block”
Header always set X-Robots-Tag “none”
Header always set X-Download-Options “noopen”
Header always set X-Permitted-Cross-Domain-Policies “none”
Header always set Strict-Transport-Security “max-age=63072000; preload”
SetEnv modHeadersAvailable true

Muss ich noch weitere deaktivieren?


(Lukas Winkler) #8

@Confuserix,

Bei mir kommt kein Fehler, aber solange der CSP-Header dazwischenfunkt wird Matomo nicht vollständig funktionieren.


#9

Hab jetzt alle Header-Defintionen deaktiviert. Vermutlich wg. des Löschen des TMP-Verzeichnis-Inhalt kommt jetzt beim LogIn folgendes:

Edit: Jetzt klappt alles. Der Browser-Cache von Firefox hat mir weider einen Streich gespielt.

Herzlichen Dank für deine schnellen Antworten!


(Lukas Winkler) #10

CSP passt jetzt, aber hier bin ich etwas ratlos. Kannst du mal einen anderen Browser probieren?


#11

Jetzt klappt alles. Der Browser-Cache von Firefox hat mir weider einen Streich gespielt.

Herzlichen Dank für deine schnellen Antworten!

Das Update hat jetzt auch geklappt!
Danke!