Matomo auto archiving fails with https

Hi everyone,

I wanted to enable the Matomo auto archiving to increase performance since I also run another program on the same server.
I have configured Matomo to only use https and when I set up the auto archiving as told here: How do I setup a scheduled task to process reports on Windows for Matomo? FAQ - Analytics Platform - Matomo

I see this 405 error when looking into the logfile of the auto archiving script:

Have you had similar issues? Does Auto Archiving only work with http?

Kind regards,


This kind of error appears when the request is not in the good HTTP verb: using POST instead of GET for example…
Can you check in the Matomo error log file (or maybe the Windows log viewer) if you see what happened?
Maybe IIS prevent the use this verb on this query?

Hi Philippe,

thank you for your Reply! I tried to install the Log Viewer Plugin to check out the logs, but the Plugin installation failed somehow, now I get this message:

And the cacls command there dows not work. Do you know what to do? I am quite lost at this point.

What is the error of cacls command?

Hi Philippe,

sorry for my late reply, I just didnt get to work on the matomo system for a while.

In my absence the write-access problem seemed to have solved itself.
However when I go to the LogViewer it appears like I get the same HTML file I put a screenshot of above.
Where else could I look for logs?
Kind regards,

Another thing that just came to my mind: Im still on V4.13.0. should I fix this before updating or should I update in hopes of fixing this?

The IIS-Logs look like this:
Software: Microsoft Internet Information Services 10.0

#Version: 1.0

#Date: 2023-02-13 00:10:12

#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) cs(Referer) sc-status sc-substatus sc-win32-status time-taken

2023-02-13 00:10:12 [IP-Address]%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2023-01-21&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 203

2023-02-13 00:10:12 [IP-Address]%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2023-01-20&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 1

2023-02-13 00:10:12 [IP-Address]f%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2023-01-18&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 0

2023-02-13 00:10:12 [IP-Address]%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2023-01-17&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 0

2023-02-13 00:10:12 [IP-Address]%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=week&date=2023-01-16&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 0

2023-02-13 00:10:12 [IP-Address]%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=month&date=2023-01-01&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 0

2023-02-13 00:10:12 [IP-Address]%3 POST /matomo module=API&method=CoreAdminHome.archiveReports&idSite=1&period=year&date=2023-01-01&format=json&trigger=archivephp& 1443 - [IP-Address]%3 Matomo/4.13.0 - 405 0 1 0

2023-02-13 00:10:18 [IP-Address] POST /matomo/index.php date=yesterday&module=Tour&action=getEngagement&page=0&idSite=1&period=day 1443 - [IP-Address] Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/ [Hostname]:1443/matomo/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday 200 0 0 780

Hi @MoelleBe
I think updating to 4.13.3 would not solve your issue, as it seems it is an IIS configuration issue…

Very strange your IIS prevent the use of POST request…
Maybe have a look at: