Matomo Archive skip grouping for elements with content interaction

Hi everyone,

this might be a very simple questions but I’m not sure if there is currently a specific setting for this. I am seeking for an option within the config file to adjust the amount of elements within “behavior” > “content” that do hold content interaction to be grouped when being archived. I’m having a page that holds content tracking with more that thousands of impressions. When elements are being archived using the default value settings, lots of them with interactions are sumed up as “grouped” as described at the faq page

Is there a specific element I can adjust to not group records that do hold interactions and maybe group more elements that only have impressions but no interactions? I would like to gain more details for the few entries a visitor interacted with without the need to increase the global amount of elements to be archived and thus risk the drop of performance.

I’m not sure which element within the settings I should tweak and increase to achieve this kind of effect without blowing up the database globally too much. It would be great if someone may be able to point me to the right direction.

Thank you for you help on this!

1 Like

Hi @domdom
Did you try with datatable_archiving_maximum_rows_standard param? (maximum number of rows for other tables (Providers, User settings configurations))

Hi @heurteph-ei
Thank you for your help. I have set this option and increased its value to 5000 to see how this affects the report. Seems like nothing changed. There are only up to 100 content elements listed and the last element is being listed as grouped. These grouped elements do also hold some interactions but I do not get the details.

Maybe there’s another specific option I can set than thedatabase_archiving_maximum_rows_standard would do?

As the configuration of number of rows in the content reports seems to not exist, I think you should create a feature request at: