Matomo 3.5.0 and the new tracker proxy


#1

Does v3.5.0 still work with the older version of tracker proxy or needs newer version at GitHub - matomo-org/tracker-proxy: HTTP proxy for Matomo's tracker API. This script allows to track websites with Matomo without revealing to your visitors the secret Matomo server URL. ?

Also instructions on tracker proxy page seem outdated as you can no longer just download piwik.php and use that as it has include files which are required too.


Matomo 3.5.0 released
(Lukas Winkler) #2

Hi,

The old tracker-proxy will continue to work, but I’d really recommend you to check out the new version as it has many new features for privacy.


#3

so new tracker instead of just downloading piwik.php needs proxy.php and config.php too ?


(Lukas Winkler) #4

Hi,

The config.php was already needed before. You don’t need to use proxy.php, but you can use it to forward the Opt-Out iFrame request.


#5

Ah forgot about config.php been ages since i did a fresh install. Thanks for clarification @Lukas