Matomo 3.11.0 -> 3.12.0 – Missing files


After upgrade to 3.12.0, system check warns about missing files:

I do understand that I can fix that on my system but I believe non-ascii characters should not be used in files names of such a popular product :slight_smile:

Good luck


Okay, this one is on me.

I assumed that in a day and age where most software uses UTF-8 out of the box, databases can store over 100000 different characters and some programing languages allow using emoji in variables, using an umlaut in a filename wasn’t a that weird concept.

It turns out I am wrong and this will be reverted in

Thanks for reporting!


Tried with the above changed files. Still the same issue persists. Following error is thrown:

File size mismatch: /plugins/DevicesDetection/functions.php (expected length: 10747, found: 10739)
Missing file: /plugins/Morpheus/icons/dist/brand/Krüger_Matz.png
Missing file: /plugins/Morpheus/icons/dist/brand/öwn.png .

Its because of missing entry in


This is to be expected as you would also need to modify the config/ as it contains the reference the matomo integrity checker checks against.
You could also just ignore those warnings until the next release.