Login fails after update and GeoIP (PHP)


i have the problem that i can not login Piwik. After using the right credentials in the login form the browser redirects to the following URL “Domain”/index.php?module=MultiSites&action=index&idSite=1&period=range&date=last7 and shows a blank page.

I recently update Piwik to version 1.9.2 and enabled GeoIP (PHP).
Looking forward for any support


Blank page? Check your server error log file


I have the same issue with Piwik 1.10.1.
When I try to login with my admin user I´m getting an Internal Server Error (500) or a Gateway Timeout (504).
The provided URL in the address bar is


When I login with a normal user (even with admin access to some sites) it works.

Would be very glad if someone would be able to solve this issue.



Please, just have a look at your error log on the webserver. It should report what’s wrong.
I assume that the memory limit has been reached and the process is canceled because of that.

Hi Thomas,

unfortunately there is only this error in the logs:

xx.xx.xx.xx - - [08/Feb/2013:10:14:10 +0100] “GET /index.php?module=MultiSites&action=index&idSite=1&period=range&date=last7 HTTP/1.1” 500 2099 “https://my.site.de/” “Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0”

the other Piwik related entries aren´t causing errors, they are getting good responses (200)

And the Apache log doesn´t contain anything related to this site.

As Piwik is running on a server with 16 GB RAM and only a few other low traffic websites I don´t think it is a memory limit issue.



Can you check suhosin memory limit? (if applicable)

No suhosin on the server…

  1. Delete your browser cache or try to access your Piwik with a different browser. If it still does not work…
  2. Delete all files in piwik/tmp/*. After deleting the files and directories, refresh the page. If it still does not work…
  3. Reupload all Piwik files from the latest version. Sometimes, there are errors while uploading files and some of your Piwik files were maybe not overwritten by the latest version. Upload all files again, and check in your FTP software that the upload was successful.

which ftp client did you use?

All suggested points already tried - still the same… - but thanks for the suggestions!

I´m using Filezilla with Win7…

You would happen to be using IE as your browser when logging in? If so which version?

I´ve tried IE 9, IE10, FF18, Chrome 24…

Can you try and turn on compatabiltiy mode.

disable Compatibility Mode in Internet Explorer 8 or 9:
Open Internet Explorer.
Click the Tools menu at the top of the window (or press Alt + T if the Tools menu is not visible) to view the Tools menu.
Uncheck Compatibility View to disable this mode.

See what results from that.

Tried it with and without compatibility mode (IE 9) but no changes. :frowning:
Piwik self seems to work fine, I´m able to see all stats over the Iphone and Ipad App

Tools - Compatibility View Settings
UNcheck all the boxes at the bottom of that settings window

  • Include updated website lists from Microsoft
  • Display intranet sites in Compatibility View this one especially

Still the same…

what php version are you running? what python version are you running?

PHP 5.3.19 (FastCGI), Phyton???

Can you try and temporarily disable fastcgi and let scriots be processed via regular cgi?

what version of fastcgi is being run?

I switched from fcgi to cgi - but still the same

I don´t know the version from fcgi - it is a managed server XL 5 - ManagedServer – Ihre Server Hosting Power, von Experten gemanagt


xx.xx.xx.xx - - [08/Feb/2013:10:14:10 +0100] “GET /index.php?module=MultiSites&action=index&idSite=1&period=range&date=last7 HTTP/1.1” 500 2099 “https://my.site.de/” “Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0”

This is the access log showing a 500 ERROR.

Therefore check your server error log to learn more what is causing this issue