Logging (mostly) does not work


#1

So,
I added new website to track. I used some online tool to generate sitemap.xml file and this visit is logged, so I know that the tracking, database and other are set up properly (or it seems like it).

However, when I (and some friends, in a time frame of ~ one day) visited the website, no visit was recorded by Matomo.

I’ve had set up other site and it worked (sometimes a bit clumsy, to tell the truth).
I don’t know much more about it, fell free to ask for details or any other information.

I’m using Matomo 3.5.0, which I updated from 3.4 version few hours ago.


(Lukas Winkler) #2

Hi,

Can you open your website and check your browsers developer tools for errors and the network tab for failed requests to piwik.js or piwik.php.

If you want to you can also send me a message with the URL to your site and I’ll have a look sometime.


#3

Both requests return 200 OK code, nothing strange can be seen. I’ve sent you the link as a message as requested.


#4

Update. I tried it in another browser (Chromium) and I see the Failed to load resource: net::ERR_CERT_COMMON_NAME_INVALID error.
The website uses valid Let’s Encrypt certificate. Does anyone have any experience with resolving this kind of issue?


(Lukas Winkler) #5

Hi,

The (Let’s Encrypt) SSL-certificate is only valid for yourpage.example, but you are also using it for matomo.yourpage.example which isn’t allowed.

So you will need to generate a second SSL-certificate for matomo.yourpage.example and change the config so that the subdomain uses it.


#6

I did that, matomo subdomain now has valid certificate and the error message from before has disappeared. However, I still cannot see any trafic in Matomo, even that it has been over 12 hours since I did that and visited it many times from different browsers.


(Lukas Winkler) #7

Hi,

The certificate is now valid for me and I just tried visiting the page and it should be counting the visit.

Do you see a visit from Austria?


#8

Yes, yes I do. I guess that just my PC is messed up, as I can see your visit.

Thanks a lot for your help. I cannot do much in return, so I’ll spread a word about this great software.


(Lukas Winkler) #9

Hi,

You probably are just using an Adblocker or have enabled DoNotTrack on your browser.

It’s great you are happy with Matomo.