LogAnalytics starts but does nothing


Piwik 2.17.1
PHP 7.0.7
Phyton 2.7.12
on Windows Server 2012

Had LogAnalytics running for years, but since July it doesn’t work anymore for me. It starts but then does just nothing.

I can run
python import-logs.py
and get the whole help text.

I can run
python import-logs.py "D:\Temp\access.log"
and get the message, that the URL is missing.

If I run
python import-logs.py “D:\Temp\access.log” --url=localhost
the python-process is starting (as seen in TaskManager) but actually nothing is happening.

I’m not really sure what I did before it stopped working. I think I just updated piwik as many times before.

Has anyone an idea, what the reason could be?

Thanks a lot!

Solved it.

You really, really, REALLY have to use Python 2.6. Not 2.7 or 3.5. Only 2.6!

(And don’t try to install more than one version of PHP. Especially not into a folder with spaces (e.g. C:\Program Files\PHP))

Hi @drhirn
The log analytics script should work and import logs also on Python 2.7. Did you get some problem with Python 2.7? if so please report here: GitHub - piwik/piwik-log-analytics: Import any kind of server logs in Piwik for powerful log analytics. Universal log file parsing and reporting.

Hmm, yes, you’re right. No idea, why it didn’t work with 2.7. Installed it again and now it’s working.

And no, no problems with 2.7.