Loading widget, please wait... in 1.71


(Adrian) #1

I was following the issue in this post, but the user has an issue with WebOS and I did not want to hijack his thread. I’d like to report an issue with Windows 7 on FF, Chrome with 1.7.1. I have upgraded successfully from 1.5, 1.6, 1.7 with no issue. I hit a snag at 1.7.1. I used both automatic, and then later manual download. The widgets on the dashboard are simply not loading despite ample time. I have deleted all items in TMP, and read the troubleshoot documentation. I got so intrigued to find an answer I totally re-installed my Piwik, and with a new database. I am still getting “loading widget”. Something strange too. I can load a “new” widget to the dashboard, and it looks great. Come back later and it too gets a “Loading widget, please wait…”. I have also tried to disable all plugins one by one, but it doesn’t seem to matter. I am simply stumped, especially because all other reports have data—it’s just the dashboard that is borked. Has anyone encountered this behavior? Any ideas/suggestions?


(Matthieu Aubry) #2

That’s quite surprising indeed. DOes the demo.piwik.org load for you?

You can try to enable DB based sessions maybe? Installation - Analytics Platform - Matomo


(Adrian) #3

Demo works. Tried the database session same error. And now to add a curveball. I have piwik running on two other sites, with exact same host setup with no issue.


I did a fresh install of 1.6.1, then I went to 1.7, then 1.7.1—there is something that is causing the widgets to load indefinitely in 1.7.1

I can load widgets fine, and then I come back and it spins indefinitely waiting to load, with the Oops message showing for half a second. Super stumped by this one.


(Matthieu Aubry) #4

Check your webserver error logs?


(Adrian) #5

Didn’t see anything strange. I downgraded to 1.7 Dashboard plugin and all works fine now. I have 1.7.1 working fine on two other servers with same setup - -so it just might be something wonky on my side.