Loading pages are too long without proxy configuration


(Cyril) #1

Hello,

Loading Matomo pages take very long time. Approximately 60sec to load the ‘home page’, after login, and in addition ~60sec to load data into this home page.
I think, something running until it gets timeout.

When I set proxy params in the section [proxy] into the file ‘config/config.ini.php’ then loading home page take less than 2sec.
How to disable all internet access of my Matomo installation and keep page loading the fastest ?

My ‘config.ini.php’ file contains :

[General]
salt = "123456 ..."
trusted_hosts[] = "... .local"

enable_internet_features = 0
enable_auto_update = 0
enable_update_communication = 0
enable_marketplace = 0

;[proxy]
;host = "my_proxy. ... .local"
;port = ....
;username = "my_user_name"
;password = "..."

Cordially
Cyril


(Lukas Winkler) #2

Hi,

You have a great timing! :smile:

Since Matomo 3.6.0 (which was released yesterday) you can disable all outgoing internet connections with enable_internet_features = 0 in the [General] section.

https://matomo.org/faq/troubleshooting/faq_16646/


(Cyril) #3

Hi,

thanks.
I installed version 3.6.0. I confirm the parameter 'enable_internet_features = 0' now works.