Le tracking ne fonctionne pas

Bonjour,

Avec un G.A Universel qui ne fait pas l’unanimité auprès de la CNIL et en voie de disparition, je pense passer l’ensemble du tracking de mes sites sur Matomo.

J’ai installé le code de suivi sur shibum-design.com, mais visiblement je ne traque que mes passages. Ce qui est un comble ce sont justement celles que je souhaite ne pas enregistrer.

C’est pas un site qui fait bcp de visites mais bcp plus en tout cas que l’unique trace enregistrée en 8 jours de temps.

Bref l’enregistrement ne fonctionne pas ou mal. J’ai sans doute loupé qq chose voire mal paramétré le suivi.
J’ai tenté de lire les aides. J’ai pas trop de soucis avec l’anglais (quoi que) mais le sujet est trop technique pour moi. Il y a bcp de choses que je ne comprends pas.
Bref je m’en sors pas tout seul, j’ai besoin d’un coup de main.

Shibum est un site WP, je ne passe pas par l’extension WP.
J’utilise le thème Enfold, je place le code de suivi dans le champ prévu à cet effet.
Shibum étant déjà suivi par Analytics, j’ai ajouté le code Matomo à la suite.

J’héberge Matomo sur mon propre NAS Synology.
Je ne suis pas très expert dans ce genre d’installation, mais à priori ça s’est plutôt bien passé.
Matomo à une installation façon WordPress, si on suit bien les recos, on s’en sort.
Version installée : 4.11

Voilà pour les infos sur l’environnement.
Si quelqu’un veut bien me donner un coup de main pour comprendre pourquoi je ne parviens pas à enregistrer d’autres traces que les miennes… je suis preneur.

D’avance merci.
Bonne journée :wink:

Bonjour @RV74,

Votre site n’étant pas référencé chez Symantec, je ne peux y accéder (pou le référencer : https://sitereview.bluecoat.com/#/lookup-result/shibum-design.com avec le service de filtrage “Blue Coat ProxySG”).

Pouvez-vous nous fournir ce code de suivi ?
De plus que souhaitez-vous suivre et ne pas suivre ?
Y a-t-il des erreurs visibles :

  • Dans la console du navigateur ?
  • Dans la console réseau du navigateur ?
  • Dans les logs Apache ou Matomo de votre Matomo ?

Bonjour Philippe,

Je rappelle que le code GA est déclaré juste avant celui de Matomo.

Code suivi :

<!-- Matomo -->
<script>
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://192.168.0.98/matomo/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '4']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<!-- End Matomo Code -->

Je souhaite suivre toutes les informations classiques données par défaut.
Audience, visite, pages vues, provenances géographiques (ça je ne suis pas parvenu à le paramétrer).

A priori pas d’erreurs, mais des avertissements :

Les voici :

### Optional checks

#### Répertoires privés requis:
 ⚠ Warning: Unable to execute check for $MATOMO_URLconfig/config.ini.php: curl_exec: SSL: no alternative certificate subject name matches target host name &#039;192.168.0.98&#039;. Hostname requested was: 192.168.0.98 ⚠ Warning: Unable to execute check for $MATOMO_URLtmp/cache/tracker/matomocache_general.php: curl_exec: SSL: no alternative certificate subject name matches target host name &#039;192.168.0.98&#039;. Hostname requested was: 192.168.0.98 ✔ Tous les répertoires privés sont inaccessibles depuis Internet.

#### Répertoires privés recommandés:
 ⚠ Warning: Unable to execute check for $MATOMO_URLtmp/: curl_exec: SSL: no alternative certificate subject name matches target host name &#039;192.168.0.98&#039;. Hostname requested was: 192.168.0.98 ⚠ Warning: Unable to execute check for $MATOMO_URLtmp/empty: curl_exec: SSL: no alternative certificate subject name matches target host name &#039;192.168.0.98&#039;. Hostname requested was: 192.168.0.98 ⚠ Warning: Unable to execute check for $MATOMO_URLlang/en.json: curl_exec: SSL: no alternative certificate subject name matches target host name &#039;192.168.0.98&#039;. Hostname requested was: 192.168.0.98 ✔ Tous les répertoires privés sont inaccessibles depuis Internet.

#### Paramétrer une tâche Cron (chargement plus rapide des rapports):
 ⚠ Warning: Pour des performances optimales et un Matomo rapide, il est vivement recommandé de mettre en place une entré CRON pour archiver automatiquement vos rapports, et de désactiver le déclanchement depuis l'interface depuis les paramètres Matomo. Apprenez-en plus.

#### Taille maximale des paquets:
 ⚠ Warning: Il est important de configurer une taille 'max_allowed_packet' dans votre base de données MySQL d'au moins 64MB. 1MB configuré en ce moment.

Erreurs console navigateur… ?
Errerurs console réseau… ? ce que j’ai mis au dessus peut-être ?
Les logs, je ne sais pas comment y accéder

Symantec, je ne connais pas.
Qu’est-ce que c’est, à quoi ça sert ?
C’est obligatoire pour Matomo ?

Merci pour votre aide… :slight_smile:

Pour info

https://192.168.0.98/matomo/
C’est l’URL qui me permet d’accéder à Matomo sur mon serveur

Et sous /Administration/Sites Web/Gérer

Et sous /Administration/Sites Web//Paramètres j’ai :
Liste globales des IPs Exclues

  • 192.168.0.46
  • 192.168.0.98
  • 82.64.51.131

Bonjour,

Plusieurs remarques…
192.168.0.98 est une adresse IP privée, donc à part vous (et ceux de votre entreprise), personne ne pourra atteindre cette adresse (à moins que le site que vous suivez est un site Intranet ?)

En pressant F12 sur votre navigateur favori, on obtient la console JavaScript. Intéressant pour observer les erreurs JavaScript ! :wink:

Toujours après le F12, il faut regarder l’onglet ‘Réseau’ ou ‘Network’. On peut ainsi voir d’éventuelles erreurs de requêtes…

Ca peut être problématique pour diagnostiquer… Qui s’est chargé d’installer votre Matomo ? Il faut voir avec lui…

Semblent être des adresses publiques (sur Internet). Y a-t-il une raison que vous excluez 1 adresse privée (Intranet) “192.168.0.46”, l’adresse privée de Matomo (Est-il possible de naviguer sur un site DEPUIS un navigateur installé sur le serveur Matomo ?) et 2 adresses publiques ?

Visiblement, il semblerait qu’il y ait un problème de certificat SSL. N’hésitez pas à effectuer les tests de répertoires privés à la main… (mais pas lié à votre problème)

Je pense que ce paramètre est à corriger (bien trop faible, mais pas lié à votre problème)

Non le site shibum-design.com n’est pas en intranet.
Par incompréhension j’avais déclaré les 2 IP locales, je viens de les supprimer des URLs exclues.
Pas plus d’erreurs JS dans l’inspecteur en tout cas pas d’erreur JS matomo.
Si les avertissement ne sont pas non plus bloquants, qu’est-ce qui coince alors ?

Oui j’ai ces 2 IP publiques que je veux exclure des visites.
Les 2 IP locales sont supprimées. Il n’y avait pas de raison de les déclarer et oui j’arrivais à naviguer… (va comprendre)

Bonjour
Il faut dans tous les cas déclarer un Matomo publique si vous souhaitez que vos clients puisse se faire traquer… Dans votre script de suivi, l’URL de Matomo est https://192.168.0.98/matomo/, privée, et donc personne en dehors de votre entreprise pourra atteindre Matomo…

Autre piste,
Au moment de la création du code de suivi, J’avais également créé un conteneur que je n’utilise pas :

Pourrait-il être une source de conflit ?
Mais ce code ne me sert à rien.
Il serait sans doute plus intelligent de supprimer ce conteneur, non ?

<!-- Matomo Tag Manager -->
<script>
var _mtm = window._mtm = window._mtm || [];
_mtm.push({'mtm.startTime': (new Date().getTime()), 'event': 'mtm.Start'});
var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
g.async=true; g.src='https://192.168.0.98/matomo/js/container_fyEftk7O.js'; s.parentNode.insertBefore(g,s);
</script>
<!-- End Matomo Tag Manager -->

C’est moi qui est installé Matomo sur mon Synology. J’ai suivi les consignes d’installation.
Pour autant je sais pas lire les logs sur mon serveurs, surtout s’il faut installer un script qq part, je connais pas les commandes unix ou debian…

Bonsoir,

À nouveau : il faut corriger l’URL de votre Matomo indiquée dans votre code de suivi. Si l’URL de Matomo est interne (192.168.0.98), jamais une personne extérieur pourra l’atteindre.

La présence du conteneur n’a pas d’impact… Sauf si vous déclarez dans vos pagez le code de suivi de base en JavaScript et le code du Matomo Tag Manager (vous traceriez alors probablement 2x). Si vous aviez l’habitude d’utiliser GTM, alors MTM sera plus simple pour vous.
Si c’est vous qui avez installé le serveur, les logs sont quelque part dans l’arborescence a priori pas trop loin de votre installation de PHP et/ou Matomo…

J’adorerai l’enlever mais cette ULR interne est inscrite dans le code de suivi…

Je me souviens avoir cliqué sur cette option de cookie dans /Administration/Personnel/Paramètre

Je m’étais fait la reflexion du double emploi puisque j’avais exclu les IPs de l’autre coté, mais j’avais laissé ce cookie installé. Bizarrement il n’est plus installé.
En tout cas l’IP de cette option (du cookie) est bien celle reprise par le code de suivi.

Est-ce que ça a qq chose à voir… ?

Ca y’est, je crois comprendre…
en fait vous me demandez de corriger l’IP 192.168.0.98 du code de suivi - qui est une IP d’accès interne à mon serveur (il n’y a que moi qui puisse l’utiliser) - par une IP publique.
Avec une IP publique, Matomo aurait accès depuis l’extérieur à mon serveur et pourrait enregistrer les visites… C’est bien ça ?

Et bien je ne sais pas accéder à Matomo par l’extérieur.
Mon serveur est accessible par le domaine twiners.fr.

J’ai une autre appli installée sur mon Synology (Dolibarr) mais elle je peux y accéder par l’extérieur. Je sais pas ou plus comment j’avais fait, en fait je ne crois pas avoir fait qq chose de particulier, mais j’accède à Dolibarr via l’adresse twiners.fr/dolibarr. (incomplète en l’état)

Mais pour Matomo, mon seul moyen d’accès que j’ai à ce jour c’est via l’IP 192.—

Ca vous éclaire… ?

Désolé pour toutes ces incompréhensions, les réseaux/serveurs, c’est pas mon truc.

Il faut donc faire le même principe que pour votre site : Si personne ne peut envoyer de message HTTP à votre Matomo, personne n epourra être traqué…

Pour votre cookie, pas vraiment de problème… ce n’est pas lui qui empêche la traque des autres visiteurs.

Aïe je suis perdu…
J’ai bien compris que personne ne sera tracké (à part moi) mais j’ai pas compris ce qu’il fallait que je fasse pour corriger ça.
“Faire le même principe que mon site…” ?
Ca veut dire quoi exactement ?

Vous avez dû faire une configuration pour que votre site (twiners.fr) soit disponible depuis l’extérieur…
Il faut procéder de même pour que votre Matomo puisse aussi l’être.
Et ensuite, vous remplacez https://192.168.0.98/ par l’URL (visible depuis l’extérieur) de votre Matomo.

d’accord je comprends.
Dès que j’ai la solution, je viendrai la rapporter ici.
En attendant il va falloir que je fouille…
Merci Philippe de m’avoir permis de comprendre quel était le problème… :wink: