Last Successful Archiving Completion data is missing from System Check


#1

Hi, I’m using Matomo 3.9.1 on my website. I’ve configured the “Web Cron” method to archive my reports, as described at How to Set up Auto-Archiving of Your Reports User Guide - Analytics Platform - Matomo because my site runs on shared hosting and this is the only method that works for me.

The Web Cron runs successfully every hour.

However, if I visit the System Check page in my Matomo settings, the “Last Successful Archiving Completion” section has a warning icon next it, with this text:

“For optimal performance and a speedy Matomo, it is highly recommended to set up a crontab to automatically archive your reports, and to disable browser triggering in the Matomo settings.”

It does not show me the actual last successful archive date and time, as I expect it to.

Is there a reason that the last successful archive timestamp is not shown here when I’m using the web cron method to archive my reports? It would be really nice to have this information provided on the System Check page, and more importantly, it would be helpful not to have the System Check page give me a false warning when nothing is actually wrong.


(asitvd) #2

I just ran in the exact same issue.

The trick is to read the end of the sentence:
“For optimal performance and a speedy Matomo, it is highly recommended to set up a crontab to automatically archive your reports, and to disable browser triggering in the Matomo settings.

I facepalmed hard.

Once your cron is enabled, disable the browser triggering, just follow this: How to Set up Auto-Archiving of Your Reports User Guide - Analytics Platform - Matomo

HIH


#3

Thanks for the tip! I just disabled the browser triggering and now it’s correctly showing the time since the last archiving on the System Check page.

The reason I hadn’t disabled browser triggering previously is because the article “How to Set up Auto-Archiving of Your Reports User Guide - Analytics Platform - Matomo” says this only needs to be done for “medium to high traffic websites”, and mine is a low-traffic website. I think the warning text in the System Check page could be improved to make this more clear.