Language switched for no reason, can't find how to change backl


#1

Piwik in Chrome switched to Swedish lang for no reason that I am aware of. Fortunately I speak Swedish, but I definitely don’t want to run the module in Swedish, since all the documenation is in English. I have been unable to find a way to switch langauge. Expect it’s in a cookie because switching to another browser meant I got the English GUI.
Surely there must be a more convenient way to switch language other than clearing the cookies!
And it’s a jolly good thing it switched to a language I actually know. It would have been even more frustrating otherwise.


#2

I suspect that your copy of Chrome has been configured for Swedish as the preferred language. Piwik, unless told otherwise, will present its pages in the browser’s preferred language. You can force a different language for logged-in users in the Settings for that particular user.

This article tells you how to change the preferred language in Chrome:

The information is accurate, but in step 4 it talks about the fifth option from the bottom. In recent versions of Chrome, it’s the sixth option from the bottom. The “Show advanced settings” link mentioned in Step 3 is very easy to miss. It took me several attempts before I noticed it! I suspect this is deliberate

You can re-arrange the order of the preferred languages in Chrome, and you can also delete languages other than US English. To re-arrange the order of the languages in the list, just drag-and-drop them…


(Matthieu Aubry) #3

To change language go to Piwik > User Settings and change language here