Keinerlei Auswertung wird angezeigt [Problem gelöst]


(Tom) #1

Hallo zusammen,

ich bin absoluter Piwik-Neuling und habe alles, wie beschrieben installiert. Leider wird keinerlei Auswertung bei mir angezeigt. Ich nutze Joomla in der Vers. 1.7.3 und habe den Java-Code in der “index.php” meines Templates oberhalb des Tags eingefügt.

Das ist der genaue Code:


	<!-- Piwik -->
<script type="text/javascript">
var pkBaseURL = (("https:" == document.location.protocol) ? "https://www.mensch-meyer.com/piwik/" : "http://www.mensch-meyer.com/piwik/");
document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
</script><script type="text/javascript">
try {
var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);
piwikTracker.trackPageView();
piwikTracker.enableLinkTracking();
} catch( err ) {}
</script><noscript><p><img src="http://www.mensch-meyer.com/piwik/piwik.php?idsite=1" style="border:0" alt="" /></p></noscript>
<!-- End Piwik Tracking Code -->
</body>

Kann mir da jemand weiterhelfen?

Die Seite ist übrigens Mensch-Meyer.

Vielen Dank vorab…


(Thomas Seifert) #2

Ich würd mal im Error Log des Servers nachschauen oder den Hoster fragen.
Der Aufruf der piwik.php beim Tracking von Deiner Seite liefert einen 403 Fehler.


(Tom) #3

[quote=“Thomas Seifert”]
Ich würd mal im Error Log des Servers nachschauen oder den Hoster fragen.
Der Aufruf der piwik.php beim Tracking von Deiner Seite liefert einen 403 Fehler.[/quote]

Hallo Thomas,

vielen Dank für deine schnelle Antwort. Ich habe sofort den Support meines Hosters (all-inkl.com) angesprochen und habe die nachfolgende Antwort erhalten:


Hallo Herr....

der Aufruf von piwik und der anschliessende 403 Fehler erfolgt durch diesen Aufruf:

/piwik/piwik.php?action_name=Mensch-Meyer&idsite=1&rec=1&r=381348&h=19&m=30&s=10&url=http%3A%2F%2Fwww.mensch-meyer.com%2F&urlref=http%3A%2F%2Fwww.mensch-meyer.com%2Fadministrator%2Findex.php&_id=ab6a74ba6ce13e82&_idts=1326032970&_idvc=17&_idn=0&_refts=0&_viewts=1326648309&pdf=1&qt=1&realp=0&wma=1&dir=0&fla=1&java=1&gears=0&ag=1&res=1600x900&cookie=1 HTTP/1.1

Leider kennen wir uns zu wenig mit dieser Software aus, um Ihnen sagen zu können was in den entsprechenden Variablen drin besteht, bzw. was diese bewirken. Ein 403 Fehler kann auch durch unzureichende Zugriffsrechte entstehen, nur leider wird dies nicht daraus ersichtlich. Eventuell kann der Moderator mit diesem Aufruf etwas anfangen?

Bei weiteren Fragen stehen wir Ihnen gern zur Verfügung.

Mit freundlichen Grüßen
Enrico Jäschke
Supportteam

Neue Medien Münnich
- Inhaber René Münnich -
Hauptstraße 68, D-02742 Friedersdorf
Ust-ID: DE212657916

Tel: +49 35872 353-10
Fax: +49 35872 353-30

E-Mail: info@all-inkl.com
Web: www.all-inkl.com

Kannst du mit dieser Fehlermeldung etwas anfangen, was mir vielleicht irgendwie helfen könnte? Ich wäre sehr dankbar, wenn ich Piwik irgendwie zum Laufen bekommen könnte.


(Tom) #4

Ich habe jetzt selbst die Lösung des Problems gefunden.

Im Tracking-Code muss vor dieser Zeile


piwikTracker.trackPageView();

diese Zeile eingetragen werden:


piwikTracker.setRequestMethod('POST');

Seit dem ich das so eingetragen habe, funktionert die Auswertung! (:P)


#5

Danke Tom! Das hat auch bei mir die Auswertung ermöglicht…


(Kutsche) #6

Hey,

ich habe das gleiche Problem. Leider hat die neue Zeile bei mir nicht zum Erfolg geführt. Noch eine Idee, was ich versuchen kann?

Gruß
Kutsche


(Reinhard Loibl) #7

Hm, stimmt. Das Problem hab ich auch.

Bei mir ist die Zeile jetzt drinnen, ich bin auch gern bereit z.B. auf skype oder so gemeinsam nach einer Lösung zu suchen, da ich eine Menge Joomla Seiten (J15 und J25) zu betreuen hab wäre es toll, wenn ich da das piwik auch zum laufen bringen würde.

Ausserdem hab ich auch das Problem das z.B. eine Webseite OHNE www. aber mit einer anderen SubDomain ausgewertet werden soll. Bsp: http://www..at und http://shop..at

Gruß Richi (flatcoated)

PS: www.austrian-bikers.at (meine private page auf der ich da rumspiel)


#8

Wir hatten auch das Problem: … Leider wird keinerlei Auswertung bei mir angezeigt.

Unser alter Code der nicht funktionierte (von PIWIK 1.7.1 generiert)


 <!-- Piwik -->
<script type="text/javascript">
var pkBaseURL = (("https:" == document.location.protocol) ? "https://piwik-stat00.ble.de/ble-piwik/" : "http://piwik-stat00.ble.de/ble-piwik/");
document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
</script><script type="text/javascript">
try {
var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 5);
piwikTracker.trackPageView();
piwikTracker.enableLinkTracking();
} catch( err ) {}
</script><noscript><p><img src="http://piwik-stat00.ble.de/ble-piwik/piwik.php?idsite=5" style="border:0" alt="" /></p></noscript>
<!-- End Piwik Tracking Code -->

Aktuell… der jetzt aktive Code der sofort funktionierte (aus PIWIK 1.4… nachgemacht)


<!- Statistik Tracking Code Piwik START ->
<script type="text/javascript" src="https://piwik-stat00.ble.de/ble-piwik/piwik.js"></script>
<script type="text/javascript">
try {
var piwikTracker = Piwik.getTracker("https://piwik-stat00.ble.de/ble-piwik/piwik.php", 5);
piwikTracker.trackPageView();
piwikTracker.enableLinkTracking();
} catch( err ) {}
</script>
<noscript><p><img src="https://piwik-stat00.ble.de/ble-piwik/piwik.php?idsite=5" style="border:0" alt="" /></p></noscript>
<!- Statistik Tracking Code Piwik ENDE ->


Es ist noch nicht klar warum der jetzt funktioniert. Die Variante mit dem Einfügen von: piwikTracker.setRequestMethod(‘POST’);
wurde nicht probiert, weil wir vorher die oben dargestellte Lösung gefunden hatten.

Realisiert in: http://www.ernaehrungsvorsorge.de/


(Reinhard Loibl) #9

Also ich habs jetzt bei 1.8.2 sowohl als standalone wie auch als joomla componente hinbekommen.

Die z.B. von 1&1 als vorinstallierte Version verwendte geht gar nicht mit Joomla, deinstalliert man diese aus dem ‘Application Vault’ genommene Version und macht eine einfach mit der 1.8.2 selber gehts interessanterweise.

Wie es scheint liegts daran das die ‘alten’ versionen sich einfach nicht mit Joomla vertragen