Issues with Changing URLs for Goals


#1

Hi there,

For our web application, we manually insert the rows necessary into our Piwik database. Everything works (well…worked) as it should. The issue that I have is that in our web app, we had to change a url, but the goal is still the same. We had a url for /apply/ which has now changed to /application/ . What we measure conversion for is still the same, but (obviously) it isn’t tracking the goal anymore.

We have about 1000 sites setup with the previous goal. I manually went into the database and changed the /apply/ parameter to /application/ in the goal table for a couple sites, but after a few days (and nearly 1000 visits and proof through other means that people are reaching the goals), the conversions were never recorded. I had to manually go in through the Piwik Admin interface, and edit the goals, save them, and then they started recording the conversions.

Ideally, I’d like to use MySQL to manually change all of these at the same time, but there seems to be a trigger or something or some sort? Am I missing something?


(Matthieu Aubry) #2

After making the change in Mysql, please try to delete all files in tmp/cache/tracker/*

this should have been done automatically (cached refreshed after few hours) but since you mention 1 full day, maybe there is a bug


#3

That was the magic trick! Thanks for your help matt.