Issue with 1.3 to 1.4 Upgrade


(jasonaward) #1

We installed 1.4, and tried running the upgrade script from the command prompt. We allowed it to run for about 30 minutes during which time there were no queries being run against the mysql database, which was the first odd issue.

We then refreshed the “upgrade” page, and it now showed:

“Piwik database will be upgraded from version 1.4-rc1 to the new version 1.4.”

We tried running the listed queries manually against the piwik database, and they promptly ran. However, this message will not go away. Here are the queries we ran:

ALTER TABLE piwik_log_visit MODIFY location_ip VARBINARY(16) NOT NULL;
ALTER TABLE piwik_logger_api_call MODIFY caller_ip VARBINARY(16) NOT NULL;
UPDATE piwik_log_visit SET location_ip = UNHEX(LPAD(HEX(CONVERT(location_ip, UNSIGNED)), 8, ‘0’));
UPDATE piwik_logger_api_call SET caller_ip = UNHEX(LPAD(HEX(CONVERT(caller_ip, UNSIGNED)), 8, ‘0’));
UPDATE piwik_option SET option_value = “1.4-rc2” WHERE option_name = “version_core”;

Any thoughts about what might be causing the upgrade page to continue to show?

Thanks for any help!


(vipsoft) #2

If you’re sure the above ran correctly (e.g., use “DESCRIBE piwik_log_visit;” to verify that the schema has changed), run:


UPDATE `piwik_option` SET option_value = '1.4' WHERE option_name = 'version_core';