Is Matomo Tag Manager still very experimental?


(Doug) #1

Gave Tag Manager a shot today and I am impressed by all of the Google Tag Manager features that have been implemented.

My experience was super buggy though. For one, container ID would randomly change and a few times I had to replace the snippet code on my site. Then I tried going into preview mode many times and it would never appear properly when I visited the site. There would be times where the page would keep going and then 502 error.

I’m on the latest version of Matomo.

Just curious if Tag Manager is still very experimental or if there’s just something wrong with my setup that is causing all of these problems.


#2

We don’t consider it experimental anymore and things should just work fine. Randomly changing containerID etc doesn’t sound quite right and maybe there is a problem with the setup. Can you explain what is eg happening when container ID randomly changes? What changes where?


(Doug) #3

Usually I would have pushed some version changes to Live and would also be trying out Preview mode. I would either not see my latest changes (For example, the preview mode would be showing a tag that was deleted firing off but not a new one I created) or the preview mode banner (on my site) would stop showing. Out of confusion I would click the “Install code” button to make sure I have the right container ID and I would see it completely change. This has happened multiple times.


#4

If the latest changes are not loaded, you may need to make sure the browser isn’t using a cached version. Re the changing containerId, I have no idea how this could possibly change. Could you show us an example just to make sure it is the containerId that changes and not something else?