"Invalid idSite" error on certain Web pages


#1

I am tracking a MediaWiki site running on localhost (my laptop) and when I try to log on to my MediaWiki site, Piwik debug output shows the following:


Debug enabled - Input parameters: <br/>array ( 'title' => 'Special:UserLogin', 'returnto' => 'MediaWiki:Common.js', )
Loading plugins: { Provider,Goals }
Current datetime: 2011-08-18 20:04:34
 # web analytics
Invalid idSite

Backtrace:
#0 C:\xampp\htdocs\wiki\extensions\piwik\core\Tracker.php(110): Piwik_Tracker_Visit->setRequest(Array)
#1 C:\xampp\htdocs\wiki\extensions\piwik\piwik.php(83): Piwik_Tracker->main()
#2 C:\xampp\htdocs\wiki\LocalSettings.php(163): require_once('C:\xampp\htdocs...')
#3 C:\xampp\htdocs\wiki\includes\WebStart.php(116): require_once('C:\xampp\htdocs...')
#4 C:\xampp\htdocs\wiki\index.php(42): require_once('C:\xampp\htdocs...')
#5 {main}

I don’t know how to debug this. My SiteID is set to “1” (it’s the only site I have and that I am tracking).


Bump to include javasript tracking code:


/* Any JavaScript here will be loaded for all users on every page load. */

<!-- Piwik --> 
<script type="text/javascript">
var pkBaseURL = (("https:" == document.location.protocol) ? "https://localhost/piwik/" : "http://localhost/piwik/");
document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
</script><script type="text/javascript">
try {
var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);
piwikTracker.trackPageView();
piwikTracker.enableLinkTracking();
} catch( err ) {}
</script><noscript><p><img src="http://localhost/piwik/piwik.php?idsite=1" style="border:0" alt="" /></p></noscript>
<!-- End Piwik Tracking Code -->