Internet explorer tracking request aborted

In our company we have a weird problem.
We have about 1500 computers and we track our intranet with piwik.
And what we see now is that round about 5% of users not get tracked, never.

I sat down to one of the computers that not work - There is a problem with internet explorer tracking.
What i see i the network panel is that the piwik.js is loaded properly with status code 200, than the piwik.php is also called properly with all the required tracking url parameters.
The status code from piwik.php is 204 No Content, which is also fine.
And now the problem: In the network panel of IE i see the “Result” of the request is “Aborted”, everytime - But in the details i have the 204 No Content header. The request never show’s up and never get’s tracked in piwik.

Even if i take the generated piwik.php url and enter it directly in the browser window, it doesn’t work. IE says it cannot open this page. If i take the same url and open it with any other browser (Firefox, chrome, safari) it works as expected and the request is instantly visible in piwik, it also returns 204 No Content as expected.

I’ve tested tons of things but i cannot get it working for IE.
What i’ve tested so far and nothing of that worked.
Used is IE 10 on Windows7 64 bit.
Piwik Version: 2.16.0
Installed on https with a correct SSL cert

  • Tried all IE security settings, disabled/enabling (tracking, addons, DNT, zones, compatibility mode
  • Disabled all security and anti virus software on the PC
  • Used InPrivate and/or Standard Mode
  • Used a whole new windows user profile on the PC
  • Tested as Administrator account and normal user account
  • Deleted and reseted all IE settings and cached things
  • Tested another webserver, PHP version and another (fresh) piwik installation

I have absoluty no idea why the hell the tracking is not working on some of our computers.
On another computer with mostly the same installation it works fine.

Have any of you some other ideas what i can try?
As i said before, this behaviour is on ~5% of our computers, which means about 100 computers.
Very weird.

This one didn’t help: Piwik does not track visits with Internet Explorer 10 ?

No, this topic as over a year old and we use always the up2date version of piwik.
As a mentioned before i’ve tested a completely fresh piwik installation and it also doesn’t help.

Hi there, this is a strange issue. Maybe you could create a bug report with your analysis on our tracker Issues · matomo-org/piwik · GitHub ?

Btw, did you confirm that all your users are using the exact same version of IE?

Are there maybe browser addons that could interfere?

Should i just copy the topic to the issue tracker?
As i said in topic post, i’ve tested also with all addons disabled (there are just the standard office pc addons installed that come with windows and ms office)
Also we’ve expanded our tests to IE11, same issue here.
We’ve stopped investing this issue because after hours of work we cannot find any more helpful information for you. The tracking is not that much essential for us.
The PCs are pretty much the same, but not equal. Differs in model, hardware and a few software tools. But in general, all are just default office pc’s.
I know that this a real ugly issue and i cannot create a reproducable case which make things not better.

What makes me a bit nervous is that this does happen for so many computers and we’ve only realized this issue because we know exactly how much people are expected for specific pages, and especially ip addresses. We noticed a big difference between piwik and our expectations, than we started to search…

Can you confirm that your Cert is valid, and is not a self signed cert? an invalid or self signed cert could be one of the reason the browser aborts the request

100%. It’s an expensive wildcard cert. The thing is also, i can open piwiks admin interface without problems, only the tracking doesn’t work.