Installing on Dreamhost


(Leander) #1

Hi, sorry for this lay question, but I am trying to set Piwik up on a shared Dreamhost server and get the following error:

Required PHP configuration (php.ini)
(OK) session.auto_start=0
(Error) always_populate_raw_post_data=-1
(Hint) To prevent some critical issue, you must set the following in your php.ini file: always_populate_raw_post_data=-1
After making this change, restart your web server.

However, I cannot access the php.ini file to change it.

Please help. Thank you so much, Leander


(Matthieu Aubry) #2

Hi there,

please contact Dreamhost to ask them about this. it’s important for Piwik to work that always_populate_raw_post_data=-1 is set. this is also important for some other apps which may break without it. Ideally dreamhost would change their default php config on PHP 5.6 to have this setting.