Installation screen is blank except "PIWIK free/libre analytics platform"


(Quantum) #1

I have started an installation of piwik but when I go to https://mydomain.com/mypiwik , I get just a blank screen except it has at the top:

PIWIK
free/libre analytics platform

then nothing under that, just a blank screen below that.

There is nothing in my error or access logs to give any hint of anything wrong.

My server’s specs:
CentOS 6.7
PHP 5.3.3
MySQL 5.1.73

The installation directory and everything within the directory is owned by apache:apache
and all files have rw-r–r-- permissions (except x for directories, of course)

From phpinfo, I can see that:

PDO
PDO support enabled
PDO drivers mysql, odbc, sqlite

pdo_mysql
PDO Driver for MySQL enabled
Client API version 5.1.73

PDO_ODBC
PDO Driver for ODBC (unixODBC) enabled
ODBC Connection Pooling Enabled, strict matching

I have tried restarting apache, but still the same result.

I initially installed it all from
wget http://builds.piwik.org/piwik.zip && unzip piwik.zip
just about an hour before posting this message.

Does anybody have any ideas about what could be going wrong or what a solution may be?


(Matthieu Aubry) #2

Hi there,

Please see our FAQ: I get 'Oops... there was a problem during the request.' or 'Internal Server Error' or '500 error' or the 'White screen of death'. How do I proceed? - Analytics Platform - Matomo