Installation problem with tmp folder


#1

I am installing Piwik for use with Wordpress.
However I got the following errors:

Piwik couldn’t write to some directories.

Try to Execute the following commands on your server:

cacls D:\www\nabuco.nl\www\piwik\tmp /t /g IUSR_53080:f
cacls D:\www\nabuco.nl\www\piwik/tmp/templates_c/ /t /g IUSR_53080:f
cacls D:\www\nabuco.nl\www\piwik/tmp/cache/ /t /g IUSR_53080:f
cacls D:\www\nabuco.nl\www\piwik/tmp/assets/ /t /g IUSR_53080:f
cacls D:\www\nabuco.nl\www\piwik/tmp/tcpdf/ /t /g IUSR_53080:f

If this doesn’t work, you can try to create the directories with your FTP software, and set the CHMOD to 0755 (or 0777 if 0755 is not enough). To do so with your FTP software, right click on the directories then click permissions.

The tmp folder is empty. I changed CHMOD to both 0755 and 0777, but with no result.
My hoster is using MySQL, so this is OK, but also MS ISS, and that might be problem. Any suggestions, esp. how ot solve?

Thanks !
Henk


#2

Problem solved:
Errors are caused by wrong CHMOD setting. However, with MS-ISS you cannot set CHMOD with e.g. Filezilla. You have to do that on the server side, in my case the hoster.