Installation not in docroot

Hello Forum,

i want to install pikik for my website:

The DocumentRoot of this website is:


For the first try i copied piwik-directory to:


…, pasted the generated code into my website and could see tracking works

That seemes to be the default-way for a pikik-installation. But to realize
handling different Versions there are allways different Versions of my
Website in different DocRoot-Folders:

/srv/www/example_01/ <-
/srv/www/example_03/ <-

… and every time a programmed an update for i first
let the domain point to the updated version (in
the example to folder:


… and after testing the new version i let the domain
pont to this folder.

Because i don’t want to update the running piwik-folder also I would like
to install piwik not into DocumentRoot-Folder but in another Folder an
the Server under:


… reachable under and later also under The Folder:


is protected by .htaccess into it.

(How) is that possible ?


You can install Piwik in a subfolder.

See also:

[quote=vipsoft @ Feb 10 2010, 04:46 PM]You can install Piwik in a subfolder.

See also:[/quote]

thank you for your tipp. i’de found tha t yet and insallend the plugin HttpAuthLogin.
First a had the problem, that my login didn’t work anymore, but after creating
.htaccess and .htpasswd based on the example and then reloading the server
displayed it’s login-dialoge and I could login and the piwik-startpage was loaded.

great success!

… but now i cannot logout anymore ;(


but do need the plugin for what I want to do, anyhow?

seems as not:

i disabled the plugin. after that the login/logout worked like before
activating. the tracking into htassess-proteced piwik-directory seems
to work. though i didn’t login to the piwik-directory the request seems
to be tracked!



the installation to the .htaccess protected folder under
works. i just adepted the .htaccess-file to allow request for piwik.

my new problem ist, that a part of my website are https-requests. the generated
piwik-tag trys to call per https and that doesn’t work, because
there is not ssl-certified.

i tried following:

i created a symbolic link that shows to, modidied the used piwik-tag but tracking doesn’t work.

is it possible to intall piwik ‘into’ a symbolic link ?