Installation issue on the same server


(Michele Marchi) #1

Hello,

same server and same hosting but different issue.

I’ve installed here:

http://www.personaltrainerauthority.com/piwik/

and it’s ok.

But here:

http://www.iliveitaly.it/piwik/

I’ve got this error message that I’m not able to solve, since I’m not an expert user.

Already opened a ticket to my hoster but they aren’t able to help me.

Please, anyone could show me how to fix it?

Many thanks in advance


(Michele Marchi) #2

Please, anyone could help me with this?

Thanks


(Michael Gonera) #3

Hi @Michele_Marchi,

it would appear that this is on some other hosting than the Piwik you mentioned as working, right? In such a case you need to contact admin supervising the server to provide Composer server-side.


#4

@Michele_Marchi Composer shouldn’t be needed to run Piwik. Could it be that you downloaded Piwik from Github instead of the piwik.org download servers?

Please see the release notes for the (currently) latest stable release: Release 2.15.0 · matomo-org/piwik · GitHub for details. More details in How do I use Piwik from the official Git repository? - Analytics Platform - Matomo.


(Michele Marchi) #5

HI,

nope both are on the same server


(Michele Marchi) #6

HI,

nope I downloaded it from piwik.org


#7

Then, what’s also possible is that the file upload to the server did not work correctly. (Because that message appears if the following file is missing: /vendor/autoload.php - either due to download from Github or due to an incorrect upload.)

I would suggest, to be sure, to repeat the entire procedure. I.e.:

Additional hint (not related to this issue, but to prevent files being shown as changed on Piwik installation check): Please always upload in “binary” mode, not the “text”/“ASCII” mode, if your FTP client allows for the latter.


(Michele Marchi) #8

Deleted the folder and reinstalled via ftp for the third time and this time it worked!!!

Thank you very much for your help and your time


#9

Please be careful with that in future - please keep “/config/config.ini.php” in place when deleting all Piwik files. Deleting everything (including “config.ini.php”) has always (or at least for a very long time) worked, but won’t when updating to Piwik 2.16.0. You’d get Unknown column ‘use_12_hour_clock’ on update from 2.15.0 to 2.15.1-b2 or later · Issue #9666 · matomo-org/piwik · GitHub. The first response there provides a fix, if you run into it.