Installation issue - going in circles


#1

Hi. I followed the installation directions until I reached the db info input, where I forgot to enter the db server address. The following message appeared:

Error: it seems you tried to skip a step of the Installation process, or your cookies are disabled, or the Piwik configuration file was already created. Make sure your cookies are enabled and go back to the first page of the installation .

I contacted my web host for info and went back to the start. To be sure that no configuration files or data were created, I deleted all the piwik directories on the server and re-uploaded the originals to the server, restarted the installation process entering the server address this time, and the message said the db tables were created. I checked, and they were. I clicked ‘next’ expecting the user screen to appear, but the above message reappeared. I was using firefox 27.0.1 with cookies enabled, had not skipped any steps, had resent the original files (so I assume there were no configuration files there), and so restarted the process. This time it found I had tables (of course), and so I had to start all over. Same story even after I deleted the tables and all the piwik files on the server, and re- uploaded the fresh files again.

After searching this forum, I followed the recommendation to try another browser, so tried with chrome 33.0.1750.154 m. Same story, same message.

Is there a configuration file hidden somewhere other than the files that are uploaded to the server that could be forcing the message?
All ideas are welcome. Thanks.


(Matthieu Aubry) #2

Can you please try to apply this patch:

Maybe this will fix the issue for you? If so , please comment in the pull request there… Thanks!


#3

Thanks Matt. I’m using PHP 5.3.3-7 and the fix is for 5.5.

I discovered the hidden files though. FileZilla was set to not reveal hidden files, thus wouldn’t delete the directories, so I guess piwik recognized their presence and took them as piwik installed. So I reset FileZilla and cleared out all traces of piwik, deleted the tables once more, and re-uploaded again. all ticks, tables created, but same message when the superuser input should have appeared.

I notice, however, that the link in the error message for going back to the first page of the installation is to /cgi-bin. That’s not where any of the piwik files are. Perhaps the superuser script is being directed there??


#4

Matt, I made the changes you recommended. The installation check notified me that the file integrity failed and to re-upload all the files again. I ignored this and the tables were successful as before, but yet again, the error returned when the superuser should have been defined.

Any more ideas?


(Matthieu Aubry) #5

Could you install the latest beta: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

Then send me by email instructions on how to reproduce this on your server (your piwik URL showing the installer+ info that you enter during install, by email at matt@piwik) thanks


#6

Hey Matt. Did you receive my data?


(Matthieu Aubry) #7

krot, I created a ticket to keep track of this bug: Error: it seems you tried to skip a step of the Installation process · Issue #4990 · matomo-org/matomo · GitHub

let’s continue the discussion on the ticket directly :slight_smile: