Install piwik with composer

Hey guys I’m trying to install piwik via composer
my composer.jsons require blocks look like this:

 "require": {
  "php": ">=5.5",
  "composer/installers": "~1.0.12",
  "vlucas/phpdotenv": "^2.0.1",
  "johnpbloch/wordpress": "^4.5.2",
  "oscarotero/env": "^1.0",
  "roots/wp-password-bcrypt": "^1.0.0",
  "roots/soil": "^3.7.0",
  "twig/twig": "^1.24.0",
  "timber/timber": "^0.22.6",
  "php-di/php-di": "5.4.0",
  "piwik/piwik": "2.17.0",
  "solarissmoke/disable-comments-mu": "dev-master",
  "wpackagist-plugin/types": "^2.0.1",
  "wpackagist-plugin/auto-subpage-menu": "^1.1.4",
  "wpackagist-plugin/posts-to-posts": "^1.6.5",
  "wpackagist-plugin/wp-extra-file-types": "^0.3.2",
  "wpackagist-plugin/wordpress-importer": "^0.6.2",
  "wpackagist-plugin/monkeyman-rewrite-analyzer": "^1.0",
  "wpackagist-plugin/codepress-admin-columns": "^",
  "wpackagist-plugin/google-sitemap-generator": "^4.0.8",
  "wpackagist-plugin/cookie-notice": "^",
  "wpackagist-plugin/wp-piwik": "^1.0.12"
"require-dev": {
  "squizlabs/php_codesniffer": "^2.5.1"

but when I run composer update, I get the following error:

piwik/piwik 2.17.0 requires php-di/php-di 5.0.0-beta1 -> satisfiable by php-di/php-di[5.0.0-beta1] but these conflict with your requirements or minimum-stability

my minimum-stability is set to dev, so that can’t be it. also, I tried composer update without the piwik line but includeing the php-di line and that worked fine. do you have any idea what requirement could be in conflict?

Hello @gruetze
this should be fixed in Piwik 3