Install error


(TheDani) #1

Hi!

When I try to install piwik, I get the errormessage problem writing temporary file '/www/truemetal.org/htdocs/cirithungol/piwik/tmp/templates_c/wrt4b89966d225ae’
I have tried to set permission to piwik/tmp to 777.

Any idea?


(rschilt) #2

Are all the pre-requisites met?


(TheDani) #3

I think so.

  • PHP version 5.1.3 or greater
    * MySQL version 4.1 or greater
    * (enabled by default) PHP extension pdo and pdo_mysql

From phpinfo();

  • PHP Version 5.1.6
  • MySQL Client API version 5.0.77
    PDO support enabled
    PDO drivers mysql, sqlite
    PDO Driver for MySQL, client library version 5.0.77
    PDO Driver for SQLite 3.x enabled
    PECL Module version 1.0.1 $Id: pdo_sqlite.c,v 1.10.2.6 2006/01/01 12:50:12 sniper Exp $
    SQLite Library 3.3.6

www.truemetal.org/cirithungol/side.php?side_id=1


(rschilt) #4

www.truemetal.org/cirithungol/side.php?side_id=1

I see “side” - shouldn’t that be “site” ?


(TheDani) #5

Nope, it’s actually norwegian for “page”, and just a name I gave the php-file. The url is anyways correct. Any other ideas?

See if there’s anything wrong with the php settings:
www.truemetal.org/cirithungol/phpinfo.php


(Christian Schneider) #6

Hi

You changed permission for tmp directory, what is about templates_c directory?

Are you sure you have correct server settings. Don’t think that it is a problem of PHP.

Regards,
Christian.


(TheDani) #7

When I set the permissions of tmp to 777, I set the perms recursively. But when I browse tmp with a ftp client, templates_c (which is a subdir of tmp) is 755. When I try to set it’s perms to 777, I get this error from the ftp client:
Respons: 550 CHMOD 755 templates_c: Operation not permitted


(rschilt) #8

[quote=TheDani @ Feb 28 2010, 10:45 PM]Nope, it’s actually norwegian for “page”, and just a name I gave the php-file. The url is anyways correct. Any other ideas?

See if there’s anything wrong with the php settings:
www.truemetal.org/cirithungol/phpinfo.php[/quote]

Sorry, I’m out of my depth.


(TheDani) #9

Any more suggestions?


(vipsoft) #10

Delete the tmp folder and its contents. Chmod the piwik folder with 777 permissions. Visit your Piwik dashboard so the web server recreates the tmp folder and subfolders. Then change the permissions on your Piwik folder back to what it was.


(Cerberus Prime) #11

you may try to change tmp dir in php.ini, or using .htaccess
I mean global tmp for php scripts


(TheDani) #12

Seems I am unable to delete the tmp-directory from the FTP-client. When I try to delete it, everything seems fine, but the directory is still there after the process. The same goes for the subfolders sessions and template_c when I dive into tmp/
Permissions of tmp is flcdmpe (0777), owner/group is 3116 501

-If I can skip the step, chmod piwik-folder only or recursive to 777?
-How do I access the dashboard without having installed piwik?


(TheDani) #13

[quote=Cerberus Prime @ Mar 8 2010, 09:14 PM]you may try to change tmp dir in php.ini, or using .htaccess
I mean global tmp for php scripts[/quote]Could you be more specific?
Then I can ask the host if he can change the settings.


(littlephoenix) #14

is the actual http_index or php_index folder moded to 777 ?


(Cerberus Prime) #15

[quote=TheDani @ Mar 8 2010, 10:04 PM]Seems I am unable to delete the tmp-directory from the FTP-client. When I try to delete it, everything seems fine, but the directory is still there after the process. The same goes for the subfolders sessions and template_c when I dive into tmp/
Permissions of tmp is flcdmpe (0777), owner/group is 3116 501

-If I can skip the step, chmod piwik-folder only or recursive to 777?
-How do I access the dashboard without having installed piwik?[/quote]

I’m sorry. PHP’s global tmp parametr is used only for session files and uploads. Options are “upload_tmp_dir” and "session.save_path"
style_emoticons/<#EMO_DIR#>/sad.gif


(vipsoft) #16

Sorry, at this point, ask your hosting provider to fix the permissions on those folders and contents, so the web server can read/write/create/delete files. The uid/gid you posted are specific to your environment.


(vipsoft) #17

And perhaps find out if there’s a newer version of php available.

There have been many changes (esp. bug fixes) between 5.2.12/5.3.1 and 5.1.6.


(TheDani) #18

I have asked my webhost provider to upgrade php, but for some reasons he wasn’t able to do it yet. I sent him a mail, this is his answer:

I have chmod’ed 777 all files and directories below the tmp folder. The
owner of the files is apache (the user that the webserver is running
under), that is why you were not able to delete the dirs and files or even
chmod them.

I am now able to delete the tmp-folder, but when trying to access Piwik › Installation, I now get a different error than before: “Error: Unable to mkdir /www/truemetal.org/htdocs/cirithungol/piwik/tmp/sessions”.
I have tried to run piwik after tmp is deleted and I have tried to re-mkdir tmp folder with 777 permissions and then run it, but same error.