Install Error about Zend/Registry.php


(killray) #1

Hello, after uploading all files (I did it 3 times) I still get the following error:

Warning: require_once(Zend/Registry.php): failed to open stream: No such file or directory in /srv/www/htdocs/web1/html/piwik/core/ErrorHandler.php on line 12 Fatal error: require_once(): Failed opening required 'Zend/Registry.php' (include_path='.') in /srv/www/htdocs/web1/html/piwik/core/ErrorHandler.php on line 12

What can I do? I can’t get through the install and I can’t see anything, just the error massage, reloaded it several times using Filezilla.


(vipsoft) #2

(include_path=’.’)

Please contact your system administrator or web host provider.

Your PHP configuration is blocking set_include_path() in index.php.

You’ll also want to make sure your config and tmp folders are writeable by the web server “user”.


(killray) #3

First thanks for the reply.

So what should be the right setting for “set_include_path()”? At the moment it’s a point (.), which path should it be?


(vipsoft) #4

Did you mean, index.php?

Whatever you do, don’t set the Piwik include path in your master php.ini
as that could affect other PHP apps.


(killray) #5

So what should I report to my hoster? What does he have to change? It’s the only script with these problems, joomla, wordpress, drupal, typo 3 and so on are working without errors.


(vipsoft) #6

Find out from your hosting provider if they support local php.ini configuration.


(killray) #7

I can override some settings, so what I have to do?


(vipsoft) #8

See http://php.net/include_path

Look at index.php to see what paths should be included. (Varies depending on what version of piwik you have.) And use absolute paths according to your environment.