Impossible de lancer PIWIK apres son instalation


#1

Bonjour
J’ai des problèmes pour lancer PIWIK après son installation.
J’ai déjà contacté le support en PV, mais cela peut interesser des personnes ayant le même problème que moi.
Alors je poste sur ce forum.

[quote=“mon premier message”]Bonjour
J’aurai bien aimé vous envoyer ce message pour vous dire que tout s’était bien passé, mais…
après

  • le téléchargement de la dernière version
  • le versement à la racine de mon site web
  • le changement de version de php sur mon serveur FREE (maintenant PHP 5.1.3RC4-dev)

Le lancement de la page (h)ttp://monsite.free.fr/piwik , j’ai le message suivant :

Error: Unable to start session. Please check that the web server has enough permission to write to these files/directories:
For example, on a Linux server if your Apache httpd user is www-data, you can try to execute:
chown -R www-data:www-data /mnt/115/sdb/9/d/monsite/piwik/tmp/sessions/
chmod -R 0755 /mnt/115/sdb/9/d/monsite/piwik/tmp/sessions/

Debug: the original error was
Zend_Session::start() - /mnt/115/sdb/9/d/MONSITE/piwik/libs/Zend/Session.php(Line:469): Error #2 session_start() [function.session-start]: open(/mnt/115/sdb/9/d/MONSITE/sessions/sess_405aff994f4192f3e5bce053ec803965, O_RDWR) failed: No such file or directory (2) Array
/mnt/115/sdb/9/d/MONSITE/piwik/libs/Zend/Session.php(Line:479): Error #2 session_write_close() [function.session-write-close]: open(/mnt/115/sdb/9/d/MONSITE/sessions/sess_405aff994f4192f3e5bce053ec803965, O_RDWR) failed: No such file or directory (2) Array
/mnt/115/sdb/9/d/MONSITE/piwik/libs/Zend/Session.php(Line:479): Error #2 session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/mnt/115/sdb/9/d/MONSITE/sessions) Array

Je ne comprends pas d’où cela provient.
Si vous pouvez m’aider, je vous remercie d’avance.
[/quote]

J’ai ajouté

[General]
session_save_handler = dbtable

dans le fichier ./config/config.ini.sample.php, j’ai créé le fichier ./config/config.ini.php avec le même code.

Maintenant quand je supprime le fichier ./config.ini.sample.php et que je verse uniquement le fichier ./config.ini.php, j’ai le message :

Zend_Session::start() - /mnt/115/sdb/9/d/monsite/piwik/libs/Zend/Session.php(Line:469): Error #2 session_start() [function.session-start]: open(/mnt/115/sdb/9/d/monsite/sessions/sess_6ce85bab70eebcfbb99ef18a6bc85b6b, O_RDWR) failed: No such file or directory (2) Array /mnt/115/sdb/9/d/monsite/piwik/libs/Zend/Session.php(Line:479): Error #2 session_write_close() [function.session-write-close]: open(/mnt/115/sdb/9/d/monsite/sessions/sess_6ce85bab70eebcfbb99ef18a6bc85b6b, O_RDWR) failed: No such file or directory (2) Array /mnt/115/sdb/9/d/monsite/piwik/libs/Zend/Session.php(Line:479): Error #2 session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/mnt/115/sdb/9/d/monsite/sessions) Array

Merci pour votre aide


#2

Aïe je pense avoir mal posé mon problème…
Ce n’est pas après l’installation ( comme écrit dans le titre) car je ne peux pas accèder à PIWIK.
C’est après avoir versé le dossier (contenant les 2460 fichiers) à la racine de mon site.
Quand je tape l’adresse http://monsite.free.fr/piwik/, j’ai bien une page avec l’entete PIWIK #web analitics,
mais juste avec le code erreur :


(Matthieu Aubry) #3

JE conseille d’activer les sessions avec la base de donnees pour resoudre ce probleme: Installation - Analytics Platform - Matomo


#4

[quote=matt]
JE conseille d’activer les sessions avec la base de donnees pour resoudre ce probleme: Installation - Analytics Platform - Matomo

Ca je l’ai bien compris.
C’est pour cela que j’ai ajouté au code du fichier ./config/config.ini.sample.php :
[General]
session_save_handler = dbtable

sans résultat.

Comme je ne peux pas “installer” PIWIK, le fichier ./config/config.ini.php n’existe donc pas.
Je l’ai créé manuellement avec le code du fichier config.ini.sample.php + [General]…etc…
sans résultat non plus.

Par dépit j’ai rajouté directement au fichier global.ini.php le code [General]…etc…
sans plus de résultat.

J’ai parcouru les différents forums de PIWIK, commentcamarche, lesiteduzero, standartux, php.net, ouvaton, developpez.net et d’autres encore, sans le moindre début de réponse à mon problème.
Je tiens à préciser que je ne suis pas ingénieur en informatique, mais ça, je crois que tout le monde l’avait compris.
Je voyais PIWIK comme une bonne alternative à Google Analitics (qui me donne des rapports de visite complètement farfelu).
Mais je ne m’imaginais pas me retrouver devant une telle usine à gaz.
Je ne désespère pas que quelqu’un me mettra sur la bonne voie.
Encore merci de votre attention.
Pierre


(Matthieu Aubry) #5

Pardon j’avias oublie de re-lire l’historique…

Je vois que le message dit qu’il ny a pas de repertoire: /mnt/115/sdb/9/d/monsite/sessions/

Peut etre tu pourrais creer ce repertoire et ca resoudrai le probleme ?


#6

Waouh !
Créer un dossier “sessions” à la racine du site i[/i] et non pas dans i[/i].
J’ai fait un pas en avant, je suis entré dans l’installation.
piwik/index.php?action=systemCheck ==>> me trouve peu de vert, un peu d’orange et beaucoup de rouge…
Je pense que vous m’avez encore sur le forum pour quelques temps. :S

Encore merci Matt et je crois à bientôt


#7

C’est bien ce qui me faisait peur, j’ai fait un pas, mais je ne sais pas où j’ai mis mon pied.
Plus de couleur, plus d’image, plus de mise en page, le CSS s’est perdu en route.
Pas facile de s’y retrouver dans le check, si ok ou non.
J’ai compris qu’il fallait ajouter des extensions dans le php.ini.
Mais comment y accéder sur le serveur de FREE ?


(Matthieu Aubry) #8

Malheureusement j’ai l’impression que ca va etre complique… Je conseille: http://alwaysdata.com/ pour un bon hebergeur :slight_smile:


#9

[quote=matt]
Malheureusement j’ai l’impression que ca va etre complique… Je conseille: http://alwaysdata.com/ pour un bon hebergeur :)[/quote]

C’est bien ce que je pressentais.
Pour ce qui est de l’hébergeur, j’ai regardé ce qu"il se faisait et effectivement alwaysdata.com semble correct.
Et en plus les stats, devinez ? …PIWIK
Mon compte est maintenant ouvert

Merci


#10

Bonjour,
voila l’erreur, je ne comprend rien !
Je suis chez SFR, avec Vista .
Merci de me depanner.

[u]Piwik et Zend_Session requièrent la ini_set () de fonction

Il semble que votre PHP a désactivé cette fonction. Pour profiter Piwik, vous devez supprimer

ini_set

à partir de votre

disable_functions

directive dans le fichier php.ini et redémarrez votre serveur web.[/u]


(Matthieu Aubry) #11

Contactez SFR et demandez leur d’activer la fonction ini_set

ou bien changez d’hebergeur ou bien: Cloud-Hosted Piwik - Analytics Platform - Matomo


#12

Bonjour
J’ai mis les files de Piwik sur mon hosting

Puis, je navigue le page http://(mon site)/analytics/

Et j’obtiens la communication

Fatal error: Call to undefined function hash() in /home/(mon site)/docs/analytics/vendor/twig/twig/lib/Twig/Environment.php on line 265

Qu’est-ce que je dois faire?

Excuser mon francais


#13

Merci, je l’ai reconnu