IIS 8 ( time-taken ) support in Piwik 2.7.0


#1

Hi There,

I have imported IIS 8 log ( including time-taken field ) into Piwik 2.7.0 successfully.

However the time-taken information is not working as " average generation time " are all 0s in the report.

May I know the “generation_time_milli” parameter is support for IIS log as well?

( I’ve tested apache CLF, average generation time is working fine in the report )

Thx


(Matthieu Aubry) #2

maybe we need to improve the code Grep string in the python script to detect the time for IIS log ?


#3

Hi Matt,

Not sure is it the regex format problem or not.

log.jpg - the log file content for import.
#Fields: date time cs-uri-stem cs-uri-query c-ip cs(User-Agent) cs(Referer) sc-status time-taken
2014-09-27 10:00:00 /api/AutoCompleteService/apiEstateAutoComplete/ keyword=%E6%96%B0%E5%85%83&callback=_jqjsp&_1411811867650= 119.247.34.224 Mozilla/5.0+(Windows+NT+6.1;+WOW64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/37.0.2062.124+Safari/537.36 http://hk.cet.com/home/Index.aspx 200 436000

result.jpg - the import error is " invalid line detected ( line did not match ) “
./import_logs.py --url=http://localhost/piwik/ /var/www/html/piwik/misc/log-analytics/test2.log --idsite=1 --dry-run --show-progress --debug --debug --log-format-regex=”(?P^\d+[-\d+]+[\d+:]+) (?P/\S*) (?P<query_string>\S*) (?P[\d*.]*) (?P<user_agent>\S+) (?P\S+) (?P\d+) (?P<generation_time_milli>\S+)"

Thanks for your help.


(Matthieu Aubry) #4

feel free to create an issue in Github as it would be nice to discuss this in an issue: Issues · matomo-org/piwik · GitHub