I must be doing something wrong


#1

Greetings to everyone,

I must be doing something wrong because when I type in my domain name the only thing that comes up is a screen from Piwik that says:

"Authentication object cannot be found in the Registry. Maybe the Login plugin is not activated?
You can activate the plugin by adding:
Plugins[] = Login
under the [Plugins] section in your config/config.ini.php

Go to Piwik
Login

Piwik.org homepage
Piwik Frequently Asked Questions
Piwik Documentation
Piwik Forums
Piwik Online Demo"

Now the problem with that is I cannot access any pages that this config ini is located. In fact I cannot even find the html or script anywhere that has anything to do with Piwik. I am trying to get my website back to showing what it is supposed to instead of this (or the traffic screen that used to show).

I have tried to view my site on another computer but the same screen shows up which lets me know that others are seeing it as well.

Any help would be greatly greatly appreciated
Thank you in advance and God bless,
Amy


(Matthieu Aubry) #2

That definitely shouldn’t happen - can you check you have uploaded the piwik files on top of your existing files?

If so please restore your website from a backup and upload piwik files in a piwik/ directory


#3

Matt thank you so much for replying,

No that’s the trouble, I am not sure where any of the Piwik files are and I have checked everywhere. What I did do was save all the html I had done on my site because I was thinking of deleting that page and starting over from scratch (deleting name and all). Do you think that would work? Right now my main concern is just getting the darn thing back up lol. Honestly, it is as if the files are incognito. If it helps, I discovered Piwik through Ipage who does the hosting.

Again Thank you!


#4

I forgot to mention, I downloaded and opted for automatic install yesterday, so it is current.


(Matthieu Aubry) #5

Or please ask your webhost. But first check that the index.php file is not piwik file but your website’s file… or try deleting this index file and try again?


#6

Thank you again Matt. I did copy the html then deleted that page and made a new one. Atleast the new one is working the way it is supposed to. I wonder if I tried it again but not do the automatic install because there still was no files or directories anywhere related to Piwik.

In any case, thank you again and God bless!