I can not log into my piwik!:(


#1

Yesterday I changed my setting of piwik. After that I can not log into my piwik. When I log into with my account, it is always show me “Fatal error: Maximum execution time of 30 seconds exceeded in …”

So I find the way to solve this problem. And I find a wrong way to change the file “piwik.php” in “piwik/core”. I modified “max_execution_time” value to zero (max_execution_time=0) in “piwik/core/piwik.php”.

And then a new problem come out. “Unable to start session” come out. When I visit my piwik, it is always show me “Unable to start session”. So I modified “max_execution_time=0” back to “max_execution_time”. But it is not work.

Anybody can help me?


(Hans Roberto Gustavsson) #2

Hi william!

Exactly what settings did you change? Is it in Piwik or in the server files? Did you make an copy of files and database before changing it?

Peace
/Hans Roberto
PS: I am no Piwik pro, just trying to give something back to the community ^.^


#3

I changed Period “Day” to “Month”. After that “Fatal error: Maximum execution time of 30 seconds exceeded in …” came out.

No copy files…


(Hans Roberto Gustavsson) #4

Sounds to me like an memory problem. What is your php memory set at?


#5

I think php memory must be default value. I never modify it.


(Hans Roberto Gustavsson) #6

Try and find out what the settings are. Here are some clues:
http://se2.php.net/manual/en/function.phpinfo.php

I have my memory set 98 mb but it is recommended to have a lot more.


(Matthieu Aubry) #7

Can you try setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ?

Otherwise when URL fails, change to period=month to period=day to use piwik