Https loading problem even though forcing ssl


I’m forcing ssl but it still seems to be looking for a http resource instead of https.

See screenshot below which contains the domain name, and the firebox output:

Any help would be greatly appreciated.

Hi there,

Please see related issue: Tracking code could use HTTPS when the Piwik server is configured to force SSL connections · Issue #7366 · matomo-org/piwik · GitHub - basically force_ssl does not yet force the tracker to use SSL but we’d like to make this change sometime.

I just entered a similar question (301 Moved Permanently) about forcing the “https:” for secure servers because I could not find this post.

I found this by accident from a github post reference…

I would vote for either making the “force_ssl” configuration also force the URL prefix, or having another setting like “force_ssl_URL_prefix” if there must be two config variables.