How to update graphs and Visits Log on new data

There seems to be some kind of caching going on that I’m having a hard time getting rid of.

I manually deleted data for a couple of days (which were incomplete testing days and thus rubbish data), using the core:delete-logs-data command. It claimed to have deleted the entries that I expected it to delete.

But the graph in the dashboard still looks the same, and looks as if those old entries are still there. I’ve tried the following.

  • Running cache:clear, core:clear-caches, core:run-scheduled-tasks, scheduled-tasks:run.
  • Deleting the tmp directory (saving a copy) from the running instance. It was simply recreated on the next page load.
  • Restarting php8.0-fpm.

Another, similar issue is with the “Visits Log” page on one of the two sites. So, I only have one site, but I’m trying both the JavaScript snippet method (site 1) and the Log Analysis method (site 2). I’ve imported the nginx log file data successfully into site 2, and it does show up in the basic stats on the dashboard, but it’s the same story with the graph, and the “Visits Log” shows no entries whatsoever, even though they can be seen in the dashboard.

Surely there must be some way of telling Matomo to just really dump all cache and re-calculate and re-aggregate everything by some means? I don’t mind if it takes a lot of time. It can take hours for all I care. It’s just really hard not being sure if I’m looking at truly updated information or not.

Any help deeply appreciated. Thanks in advance.

I think you have to invalidate the data either with

or with plugin:

Thanks for the response.

I’ve installed the plugin but can’t figure out where to actually ask to invalidate the reports. I see no button anywhere I’ve looked. Even though the FAQ says “You can use this free plugin by InnoCraft to invalidate your historical data directly within the user interface in just one click”. I can’t find that “one click”.

The associated command line also seems to do something when run, but still the old graph is there and the aggregated numbers in the site list.

[root@chase /var/www/something]# sudo -u www-data ./console core:invalidate-report-data --dates=2020-01-01,2022-01-01 --sites=1,2
INFO [2021-12-21 15:34:35] 32631  Invalidating day periods in 2020-01-01,2022-01-01 [segment = ]...
INFO [2021-12-21 15:34:36] 32631  Invalidating week periods in 2020-01-01,2022-01-01 [segment = ]...
INFO [2021-12-21 15:34:36] 32631  Invalidating month periods in 2020-01-01,2022-01-01 [segment = ]...
INFO [2021-12-21 15:34:36] 32631  Invalidating year periods in 2020-01-01,2022-01-01 [segment = ]...
[root@chase /var/www/something]# 

The docs then say that one should archive things again, with ./console core:archive --force-all-websites --url=YOUR_MATOMO_URL_HERE, which I have also done. Still the same old stale data.

This is starting to become the number one frustration; just seeing new data.

Any ideas?