How to ignore visitorReferrer from payment gateways?

Hi,

On the Ecommerce log, sometimes the referrer website of an order is listed from one of my payment gateway. I understand this is coming from the last visited external URL of that session (after payment made). Is there a way to ignore these URL, and instead use the first external URL when the session was created (probably direct entry, or Google)?

Thanks.

@oxcid it looks like this is a missing feature maybe in Matomo. I would suggest to try configuring the URL/domain of the bank as a site URL and then it might work but configuring site urls is disabled in Matomo for WordPress since the blog url is automatically configured. If you are familiar with DB, you could probably try to configure this manually by adding an entry to wp_matomo_site_url like this

@thomas_matomo Thanks, I’m ok with DB. But I’ve just realized that the referrer text is not always the same as the referrer URL:

The text is the payment gateway, but the URL is pointing to my site. Just to confirm, which of these should I insert into the table?

Thanks.