How do I turn off Auto Archiving?


This is no doubt a dumb question: How do I turn off Auto Archiving? It’s an installation on a site with very low traffic, so Auto Archiving is not needed. I just can’t seem to find where to turn it off in the documentation.

After updating to 4.0, I get this alert in System Check:

It looks like both browser and auto archiving are enabled. Auto archiving last started 1 days 0 hours ago. If auto archiving is enabled, you should disable browser archiving in “General Settings”.

Thanks very much.


I know the naming isn’t ideal, but this setting is the one you are looking for (the top one in the general settings):

It seems like I didn’t read your message properly and you want to do the oposite:

The Auto Archiving is the cronjob you probably set up ( You can delete it if you have very low traffic, but keep in mind even with low traffic having the reports already generated when you open Matomo means that the whole UI loads faster.

Thanks Lukas!

I never did set up a cronjob, but apparently there is one as I can see the cronjob on CPanel. But I’m a lowly front end designer, so I would have remembered trying to figure it out. It was a softaculous install, so maybe it does it automatically, or perhaps the very good tech support from the hosting service did it.

Archiving last ran successfully on Wednesday, November 25, 2020 6:24:01 PM which is 1 days 03:08:17 ago.

So I’ll wait and keep my fingers crossed that all is well.