How do I solve the problem of "Server sent charset unknown to the client."?


(Simon Thopd) #1

Have a look at: https://bugs.php.net/bug.php?id=74461
and: MySQL Bugs: #85946: MySQL 8.0.1 breaks php compatibilty .
Where should I change the CharSet setting: in Matomo? in MySQL? in PHP?


Hello,
I have updated the live-site to v3.6.0 and still get the same error when I ‘Setup a Website’.
Error:
Cannot connect to the database:
Server sent charset unknown to the client. Please, report to the developers


How do I solve the problem of “Server sent charset unknown to the client.”?!
I have newly installed the Matomo analytics site on my Production server.
On my production server, I get an error when creating the first site-to-be-analyzed by Matomo.
Error:
“SQLSTATE[HY000] [2054] Server sent charset unknown to the client. Please, report to the developers”

I see that within many PHP-code pages of Matomo, the character set for database handling is set -hard coded- to UTF8 !
Please developer, change this -hard coded- setting into a flexible variable that every webmaster can maintain in the config-file (…\config\config.ini.php).
or change the -hard coded- content to the a modern character set variant, such as: utf8mb4 .

Any help would be appreciated.

Friendly regards,
Simon

Environment:
Matomo 3.5.1
MySQL 8.0.12 (different port)
PHP 7.2.7
IIS 10 webserver on Windows 10 pro OS