Help test: Piwik 1.2 last RC version before release in a few days


(Matthieu Aubry) #1

Hello

This is the last RC before final 1.2 release! Please help test Piwik now.

We’ve been working hard on the next Piwik 1.2 release, with a lot of goodness:

  • Custom variables, up to 5 per visit. See JS doc
  • Segmentation, available in the API. See API documentation
  • 1st party cookie implementation: Piwik does not use 3rd party cookies anymore!

But also:

  • Performance improvements for large traffic websites in Archiving Process: less memory consumption and can be up to 30% faster.
  • new API functions to easily request the data for one Page URL, Page Title or Download. See the new functions - Actions.getPageUrl, Actions.getPageTitle, Actions.getDownload, Actions.getOutlink. See API Reference
  • Admin UI: better usability and look and feel (design now consistent throughout Piwik!)
  • and much more

[b]Download 1.2-RC[/url][/b] and [url=http://piwik.org/docs/update/]update your Piwik (after backing up your data)

Please try it out on a test server (or installed next to Piwik 1.1.1 on your website).

Thank you to all that can help and test,


#2

Hi,

Reply to matt’s post in this topic (1.2 beta bug report).

The update of global.ini.php fix the strong warning, but I still have something wrong:

8<--------
Input parameters:
array ( ‘idsite’ => ‘1’, ‘rec’ => ‘1’, )
Loading plugins: { Goals,Provider }
Current datetime: 2011-02-23 09:41:02
Action is a normal page view, Action name: , Action URL =
COOKIE piwik_visitor, rows count: 2, cookie size = 168 bytes array ( 1 => array ( 1 => ‘’, 11 => 1, ), 2 => array ( 11 => 0, 1 => '’, ), )
Visitor doesn’t have the piwik cookie.
Error query: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘visitor_days_since_first’ in ‘field list’ In query: SELECT idvisitor, visit_last_action_time, visit_first_action_time, idvisit, visit_exit_idaction_url, visit_exit_idaction_name, visitor_returning, visitor_days_since_first, visitor_count_visits FROM piwik_log_visit WHERE visit_last_action_time >= ? AND idsite = ? AND config_id = ? ORDER BY visit_last_action_time DESC LIMIT 1 Parameters: array ( 0 => ‘2011-02-22 09:41:02’, 1 => 1, 2 => ‘-ìHPhp’, )
Nothing to notice => default behaviour
End of the page.
array (
‘piwik_visitor’ => ‘1=:2=:_=’,
’_pk_ref_9b676e5c’ => '
’,
‘PIWIK_SESSID’ => ‘****’,
)
Time elapsed: 0.032s
8<--------

When I update my piwik, it does not display to me a warning to perform an update on the db scheme.

By the way, I tried (with 1.2rc4) to install a clean version with an existing database, but I have only two option: changing database or erase all tables. Piwik cannot be installed on a database already build with existing data ?

Thank you for your help.


(Matthieu Aubry) #3

If it does not display a DB update, it means some files were not uploaded properly… please try and reupload all your files.

What is the content of core/Version.php ? It should read 1.2-rc5

The error is that your DB was not upgraded


#4

Hum… I was directly on the svn repository (trunk).
Well, I’m sure I do something wrong. I tried with the tarball with no success.
Is there a irc channel ?


#5

Not sure if this is a 1.2 specific bug or not. But I am currently using 1.2rc3.

Trying to use the Actions API using this call:

?module=API&method=Actions.getPageUrl&idSite=1&pageUrl=$url&period=day&date=last1&format=JSON&token_auth=$tkn

I get this error:

Fatal error: Call to undefined method Piwik_DataTable_Array::getRows() in /stats/plugins/Actions/API.php on line 127

Of course I suppose I might have a malformed URL thats causing this, but thought I would bring it up since 1.2 is about to go live.

*Edit - The forum doesn’t seem to want to post the request url properly…


(vipsoft) #6

We don’t recommend using trunk for production use. There are times when it may be unstable or feature incomplete. In particular, update scripts and version numbers may be advanced or rolled back. For example, if your database thinks it’s running a newer version (e.g., “1.2” final), then it won’t run the update scripts between 1.1 and 1.2 (e.g.,1.2-rc1, and 1.2-rc2).


#7

‘Visitors in Real Time’ is hardly “real time”.

I posted about this for RC3: 301 Moved Permanently

It continues to be a problem in RC5. The latest entry in the ‘Visitors in Real Time’ widget is five hours older than the latest entry in the ‘Visitor Log’


#8

I get a lot of errors using the visitor generator plugin (however it works).

I attach the file with all errors.

EDIT: I’ve updated by svn from 1.2 beta to the latest, but no statistics are shown. If I erase the piwik_archive tables they are recreated and filled qith data, but I cannot see any statistics in any tab.
When I did the upgrade it didn’t ask me to do any DB upgrade, is this correct for an upgrade 1.2beta -> 1.2RC?


#9

This is for RC5.

I have the default date range set for one week.

Today (2/28) the range is set for: Date range: 2011-02-28 to 2011-03-06

The bug is that the Visitor Log for this date range only shows the last five visits, stop at the earliest time of: Mon 28 Feb - 15:20:24

However, if I change the rage for one month, I see the 17 missing visits also logged today (the 28th). These visits are between:
Mon 28 Feb - 07:28:26
and
Mon 28 Feb - 13:42:03

If I switch back to Week range, the visitor log is cut back to just the last five visits again.


(Elam) #10

I had upgraded to RC5 . Now the piwik is not capturing the Referrer data . i can see only the Directy visit not any of the referrer data ?

any idea what will be the issue ??

Elam


(Matthieu Aubry) #11

Elam, what is your website URL? do you still experience the issue for visitors today?


(Thomas Seifert) #12

Just did the upgrade over here. Upgrade went through without problems and no issues so far.
I’ll let you know after the next archiving run tonight (usually takes around 3 hours).


(Matthieu Aubry) #13

Thanks Thomas. I think we will release 1.2 in the next few hours!


#14

Browsing with IE9 RC does not show the dashboard! This is a bug you should correct because IE9 will be RTM in a couple of weeks.

Furthermore the localized italian string “Località & provider” should be “Località e provider”.

Thanks


(Matthieu Aubry) #15

fbi1970 do you have the bug on the demo with IE9 ?


#16

Yes. Attached you can find a screenshot of demo. I get the same result with 1.2 RC5 on my web server.

Thanks


(Matthieu Aubry) #17

Thanks can you please create a ticket? thanks


#18

I just created the ticket with some details about a javascript error which blocks the javascript execution on IE9 rc.

Thanks for you work


(Elam) #19

Matt,

Sorry i did not seen your message yesterday. Well the issue is solved . i had deleted the files in temp folder and after that referrer started to show the value . i guess the latest tracker is not cached :slight_smile: .

Well the things are solved now.

Elam