Heatmap Plugin error in System Check


#1

OS: Windows 2016 R2
IIS: 8.5

Error in System Check:

Requesting ‘https://dev-piwik/plugins/HeatmapSessionRecording/configs.php?idsite=4&trackerid=5lX6EM&url=http%3A%2F%2Ftest.test%2F’ resulted in an SSL error. Maybe you are using a self-signed certificate? Please open the URL manually in a browser to see if the response contains ‘Piwik.HeatmapSessionRecording’. If not, you might need to modify your server configuration as this file needs to be accessible via a browser from the Internet or Intranet.

Error in Browser:

HTTP Error 404.5 - Not Found
The request filtering module is configured to deny the URL sequence.
Most likely causes:
•Request filtering is configured for the Web server and the URL sequence is being denied.
Things you can try:
•Verify the configuration/system.webServer/security/requestFiltering/denyUrlSequences settings in the applicationHost.config or web.config file.
Detailed Error Information:
Module
RequestFilteringModule
Notification
BeginRequest
Handler
PHP via FastCGI
Error Code
0x00000000
Requested URL
https://dev-piwik:443/plugins/HeatmapSessionRecording/configs.php
Physical Path
D:\piwik\plugins\HeatmapSessionRecording\configs.php
Logon Method
Not yet determined
Logon User
Not yet determined
More Information:
This is a security feature. Do not change this feature unless the scope of the change is fully understood. To allow the URL sequence for the request, remove the denied URL from configuration/system.webServer/security/requestFiltering/denyUrlSequences.

I have disabled Requestfiltering by modifying the web.config with the entry below.

  <security>
     <requestFiltering>
        <denyUrlSequences>
           <clear />
        </denyUrlSequences>
        <fileExtensions allowUnlisted="true">
           <clear />
        </fileExtensions>
     </requestFiltering>
  </security>

Not receiving much help from the Matomo support so any help would be great. Thanks


#2

What information can I provide to get someone to take a look at my issue?


(Jason) #3

Please try disabling the request filtering using the below method.

To disable Request Filtering:

  1. On the taskbar, click Start, point to Administrative Tools, and then click Server Manager.
  2. In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS).
  3. In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add Role Services.
  4. On the Select Role Services page of the Add Role Services Wizard:
    → un-select Request Filtering,
    and then click Next.
  5. On the Results page, click Close.