Google Analytics Importer: Error

Hi everyone

I hope someone can help figure out how we can solve this error when trying to run a Google Analytics import.

The error is:

error
Error Message: Error on day (unknown), WP DB Error: WordPress database error: Processing the value for the following felt failed: name. The specified value may be too long or contain invalid data.
These errors are unexpected and will likely persist every time you run the import on this day. To solve this problem, please ask in the forums. If you can provide access to your GA account to a member of the Matomo support team, it will provide a faster resolution.

In Diagnostics, we do have a warning regarding max_allowed_packet which is currently set to 16MB and is suggested to be 64MB. Is this the problem?

I tried both setting a date for the import and tried without any specific dates but it made no difference.

Any idea on what the issue may be?

Thanks.

Anyone with a clue on what the issue may be?

Hi @mg2022 thanks for reaching out.
Can I firstly confirm if you are using Matomo On-Premise?

Have you tried increasing max_allowed_packet to 64MB ? And seeing if this helps at all.

Hi, thank you for replying.

I am using Matomo On-Premise.

I have not tried increasing it to 64MB since the error does not say this is the issue. There must be something related to some name? “Processing the value for the following felt failed: name. The specified value may be too long or contain invalid data”

Hi everyone,

we have the same issue.
In our case we use Wordpress and we’ve installed Matomo and Google Analytics Importer plugins (all updated at the lated version). On the same server (so with the same configuration) we have lots of other websites without any problem during Analytics importation.

If I try to import via ssh the error I have is “Failed to import property entities, aborting” and in the backend of the Google Analytics Importer plugin in Matomo we have the following error:

Error message: Error on day (unknown), WP DB Error: WordPress database error: Processing the value for the following field failed: name. The supplied value may be too long or contains invalid data.

In our case I’m trying to import from an Analytics 3 property and I always have the error. On the same installation I’ve tried to import from an Analytics 4 property and all works fine. I think that the issue happened when we import from an Analytics 3 version when there is also an Analytics 4 version on the same Google Analytics account. Is that possible?

I hope this information could help you to solve this issue.

Thankyou to everyone that could help in this.

Could anyone help us?

@V.K, do you have any idea?

Hi @madeincima

From what I can see in the code, this error message (Failed to import property entities, aborting) could be encountered when the importer fails to import Goals, Custom Dimensions and Custom Variable slots.

This combined with the database error message indicates that one of the above entities that are trying to be imported may be too long and cannot be imported into the database.
In the Matomo database, a Goal can have a name of up to 50 characters and a Custom Dimension can have a name up to 100 characters.

Could you check if you’re perhaps trying to import one of those that are above such a limit? If you can confirm that, then you may be able to directly modify the column in the respective database to support the longer name.

2 Likes

Hi @rstark
thank you for your reply, it helps!
I’ve changed some goals name (in Analytics 3) and now the import via ssh starts but… I have another error! :grinning:

The new error is the following:
"Failed to reach GA after 30 attempts. Restart the import later. Last GA error message: Unknown metric(s): ga:goal3448676474Value, ga:goal3448676474ConversionRate, ga:goal3448676474Completions, ga:goal3853733353Completions, ga:goal3853733353ConversionRate, ga:goal3853733353Value For details see https://developers.google.com/analytics/devguides/reporting/core/dimsmets."

I don’t really know where to put my hands to solve this too…
Any help will be really appreciated.

Thank you!

If you restarted the existing import after changing some of the Goal names in GA, then it will fail to find the ones that it already imported. (Because the ones it created at the start of the import may no longer exist in GA)

Could you maybe try to import to a new Website/Measurable in Matomo and see if the same error message occurs?