Goals Not Showing Despite Tag & Trigger Firing

Hello matomo community.

I seem to be having a problem with matomo goals despite trying numerous methods.

I have a self hosted install with no errors, just a full house of green lights.

Basically I’m trying to record a form submission as a goal which is fairly simple in GA & GTM.

I’ve tried manually triggering a goal conversion with the standard tracking script using:
_paq.push([‘trackGoal’, 1]);

I’ve also tried deploying Tag Manager (replacing the tracking script with the tag container script) and used the Preview mode to confirm Tags & Triggers are firing as expected.

Despite this and running matomo diagnostics (no failures) I don’t seem to be able to find any problems and I remain unale to record goals.

Any advice on how to debug this would be gratefully received.

Currently, I’m sticking with the Container deployment and have the following configured;

General Enquiry
Triggered when Visitors = Sends an event
Where Event Name contains = General Enquiry

Form Submit - General - Matomo - associated with main Matomo Configuration
Tracking Event = Event
Category = Form
Action = Submit
Event Name = General Enquiry

Form ID contains gform_1

The preview shows all Triggers and Tags firing.
I’ve also tried underscoring the space in the event name and it made no difference.

I’m testing from a different device so IP is not excluded and pageviews track without problem.

Is there something I’m missing ? About to head back to Google Tag Manager as it just works.

Many thanks,

Ok, I found the solution.

If you have a Tag that sends an event name phrase, let’s say “orange” and you set the goal to record using contains “orange”, it won’t trigger.

When you have an exact phrase match you must use “exact” as “contains” (unlike Google tag manager) will fail on an exact match.