Goals Aren't Working


#1

I have 4 goals setup and none of them are generating any stats. The pages do contain the tracking code (i checked page source from browser window) and ive even manually tried triggering them by doing what the goal is set up to track and nothing is being tracked.

Everything else appearing to be working find. Any idea what’s happening?


(Matthieu Aubry) #2

Have you waited a few days for other visitors to view the goals maybe?

Also you may try to debug the tracking via: http://piwik.org/docs/tracking-api/reference/#toc-debugging-the-tracking-api-requests


#3

Data is logging because everything else in Piwik works fine (visitor logs, etc.). It’s just goals that are broken.

I might be misunderstanding goals for downloads: my page contains the tracking code and the file downloads are direct linkes to executables. Does piwik only track downloads when the file is downloaded through a (php) script?


(Matthieu Aubry) #4

Do you see the Downloads in Actions>Downloads?

see : New to Piwik - Analytics Platform - Matomo


#5

It shows them there but i need to know exactly how many downloads occurr each day which is why i need goals to work.


(Matthieu Aubry) #6

To know downloads per day, click on the download line, there will be an icon for Row Evolution: Row Evolution - View and compare historical data - Analytics Platform - Matomo


#7

After scouring the forum pages I can’t seem to find anything closer than this thread.
“MY” goal is not working.
I’ve tried multiple settings.
Everything else in the tracking is working fine. I can see the orders, see when the orders were made, see the abandoned carts, etc. But when I go to my specific goal, there is only 1 conversion.

In the last 2 days there have been about 10 orders. All of the date in Piwik shows precisely how those orders were made, for what, etc. But when I attempt to look at the goal I created, there are only 2 conversions.

In “Goals Overview” there are 12 conversions.

My goal is triggered "when visitors visit a given URL.
I tried “is exactly” for the first 24 hours and then switched to “contains” for the next 24 hours because I didn’t get any data in my goal after reviewing the confirmed orders during that first 24 hour period.

The URL is what I confirmed during a test purchase, and, I confirmed it’s the same using the data compiled from the various confirmed orders.

When I had it set to “exactly”, it contained the entire URI beginning with http://

Since that didn’t work I changed to “contains” with only the shopping-cart/confirm.
I’m going to try to put the forward slash before “shopping” to see if that will help.

Any suggestions?
Should the URL contain the single quotes?


(Matthieu Aubry) #8

can you post a screenshot of your goal definition, and a screenshot showing the page that should trigger this goal? can you also see this page URLS in the Actions>Pages report (which will indicate the pages are tracked)