Getting IPv6 error when my Matomo server sends me new version email

We run a nightly cron job

php core:archive --url= > matomo_archive_log

For the last two updates (including last night’s), when there is an update Matomo sends an email notifying about this. When it does, the cron job throws an error:

sendmail: warning: inet_protocols: disabling IPv6 name/address support: Address family not supported by protocol

postdrop: warning: inet_protocols: disabling IPv6 name/address support: Address family not supported by protocol

We don’t use Matomo for any other emails, so I would rather just not get these emails and update when I see the message on the console. And/or/but if there is an easy way to fix the email functionality that would probably be good anyway. How do I do that, though?



This error message doesn’t come from Matomo and I think not even from PHP. PHP calls sendmail to send its emails and postfix (which I think you are using to send those mails) then throws that error because it is not configured correctly:

Thanks Lukas. The error may not come from Matomo, but the email being sent comes from my Matomo instance, right? That’s what I assume because the error seems to happen every time a new version is available. So if I could turn off the email sending which doesn’t functionally add anything to how I use Matomo, I would also eliminate that error. So, is there a way to stop my Matomo instance from sending me that update email? Thanks!


The email is probably triggered by Matomo and honestly I don’t know a way to disable emails.
As the same would happen with mails from other PHP applications, you could set the sendmail path in the PHP config to something else.

But you could also just fix the postfix config, which should be pretty simple.

That’s pretty sad. So Matomo has a task (that has nothing to do with emails) it suggests I run via cron job. Matomo then decides to stick sending of an unsolicited email into that task. And this “feature” can’t be disabled. If email is not set up for the Matomo instance because it’s not used, the "“feature” results in the cron job throwing an error. The suggested solution is to set up email correctly. Presumably so that my Matomo instance can send more unsolicited emails I also can’t configure?