Getting Errors I Can't Figure Out

I’m getting these errors; I’m using Matomo installed in a Cloudron instance hosted with Linode. I’ve tried restarting the app in my Cloudron dashboard, and I don’t see anything in its logs. Also, to be clear, I’m the admin.

Now it’s gotten weirder, the dashboard (for most of my sites) looks normal but for some, there are errors in some of the boxes and for others, there are warnings above the stats.

While trying to capture screenshots, it reverted to the error I initially got.

Also, when I go off the main page I get this error:

I discovered when I refresh the page the stats now show but I still get that warning.

The “Warning: … errno=28 …” is similar to this:

Either the appropriate permissions are missing or there is not enough free space.

The "Oops… " is more complex. This has something to do with archiving, i.e. creating statistics (reports) from the raw data. Matomo stores both the raw data and the reports in the database. What can be seen in Matomo are the reports.

The creation of reports is triggered by default when the statistics are viewed. So-called “browser triggering”. You can deactivate this in the settings:
System → General settings → Archiving settings → Archive reports when viewed from the browser.
But than, no reports are created. Unless there is a cronjob set up. When this "Oops… " is displayed, then a cronjob should be set up. Depending on the amount of data either daily or hourly. And if the “Oops…” is still displayed, then increase the interval. But it’s a little more complex than that. Because this “Oops…” also appears when there is a timeout while archiving due to browser triggering. To exclude a timeout, either increase the PHP max_execution_time, or … the problem needs to be explored more deeply. For this purpose, log files must be created for the cronjob. These log files must be checked manually. It is enough if only the file size is checked. If this is a few kb, then the interval is OK. If they are more than 100 kb or even MB, then the interval is too low - the work is too much for the cronjobs. If the interval is set so that the work for the cronjobs is not too much, the browser triggering can be disabled, as well as the PHP max_execution_time can be lowered again (because it should not be too high). After that, matomo is really fast.

a cronjob with log files:

20 * * * * php /path/to/matomo/console core:archive --url= > /path/to/logs/matomo-archive-$(date +"\%Y\%m\%d\%H\%M\%S").log

cronjob tutorials: