GET request to piwik.php failed


#1

When Installing Piwik, as a subdomain, I got the following message:

“403
GET request to piwik.php failed. Try whitelisting this URL from HTTP Authentication and disable mod_security (you may have to ask your webhost).
After making this change, restart your web server.”

Has anybody seen this before? Can you tell me what to do about it?

Thanks,

Jim Morris


(Matthieu Aubry) #2

Hi there,

see: How do I configure my server to let Piwik serve HTML files? - Analytics Platform - Matomo


#3

Hi there,
sorry, but I don´t know what this link above is all about. Could you please explain what to do when facing this problem?

I first had a failure when updating piwik automatically. Then I deleted all files and database tables to install it from a scratch. And now I get this message in the 2nd step of the installing routine:

Tracker Status 500
GET request zu piwik.php fehlgeschlagen. Versuchen Sie, diese URL in die Whitelist von mod_security und der HTTP Authentifizierung aufzunehmen.
Nach dieser Änderung müssen Sie den Webserver neu starten.

I have no idea how to edit mod_security, which URL I have to include in what and how to restart the webserver :frowning:

Thanx for your help.

Best,
sv2015


#4

I am see this 500 issue also.

New install of v2.15.0. On second step of install, when checking system and files, this error is reported:


 500
GET request to piwik.php failed. Try whitelisting this URL from HTTP Authentication and disable mod_security (you may have to ask your webhost). For more information about the error, check your web server error log file.
After making this change, restart your web server. 

It is not to 403 error that the description talks about. The apache error log shows:


[Mon Aug 17 17:21:47.322087 2015] [:error] [pid 13689] [client 172.19.12.10:50462] PHP Fatal error:  Uncaught exception 'Exception' with message 'The configuration file {/var/www/html/config/config.ini.php} has not been found or could not be read.' in /var/www/html/core/Application/Kernel/EnvironmentValidator.php:64\nStack trace:\n#0 /var/www/html/core/Application/Kernel/EnvironmentValidator.php(45): Piwik\\Application\\Kernel\\EnvironmentValidator->checkConfigFileExists('/var/www/html/c...', false)\n#1 /var/www/html/core/Application/Environment.php(185): Piwik\\Application\\Kernel\\EnvironmentValidator->validate()\n#2 /var/www/html/core/Application/Environment.php(94): Piwik\\Application\\Environment->validateEnvironment()\n#3 /var/www/html/piwik.php(56): Piwik\\Application\\Environment->init()\n#4 {main}\n  thrown in /var/www/html/core/Application/Kernel/EnvironmentValidator.php on line 64, referer: http://cmp02-piwik01.xxxxxx/

The referenced file (config.ini.php) does not exist in the install package.

I have found issue #8417, but the resolution discussed there has not effect.

Any ideas?
Thanks


(Geob) #5

Nothing new on this issue ? Trying to install 2.14.3 and it still failing at this status check


#6

The link that Matt posted was useful to me.

Since I was using Apache as webserver, I just put


AddHandler text/html .html

in the section of the Apache host config. For me, the config file was in


/etc/apache2/sites-enabled/000-default.conf

To restart the webserver, I ran


sudo /etc/init.d/apache2 restart


(Geob) #7

I’ve just ignore the warning and installed the whole thing anyway, and then on the system check page in administration, Tracker Status is ok.

Maybe it’s nothing, but thanks anyway, should help other people :slight_smile:

Cheers!