GET request to piwik.php failed But no mod_security installed


#1

Hello,
When I try to install Piwik I get this error:
"Tracker status 403
GET request to piwik.php failed. Try to whitelist URL from HTTP Authentication and deactivate mod_security"
I contacted my hoster. Mod_security is not installed.
How do I whitelist an URL from HTTP Authentication?
Or is there another problem?

Regards, Capo


(Matthieu Aubry) #2

Can you check in your server error log file whether you find an error there for the piwik.php request?


#3

Hi Matt,
Thanks for your reply.

There are no errors in the apache logs regarding Piwik.

There is another problem (maybe related to the HTTP authentication - I don’t know): no images are shown, all images are broken, see screenshot.


(Matthieu Aubry) #4

if you right click on an image, and click “view image” do you see an error message?


#5

Hi Matt,

Yes, the error is
Foutcode: ERR_TOO_MANY_REDIRECTS


(Matthieu Aubry) #6

there is an issue on your server because this image should load corrrectly, can you ask your host?


#7

Hi Matt,

Your latest reply lead me to the htaccess on my main domain (Piwik is installed on a subdomain).
I now know the problem is because of the prevent hotlinking rules in my htaccess on my main domain.
I have deleted the prevent hotlinking to png and gif files, now Piwik is working… a bit.

It’s not tracking visitors and I cannot add websites.
At this moment the FAQ’s are not helping me out with this.

I leave it for now and will look into it later.
Hopefully I will get it working.

Thanks for helping.

Cheers, Capo