geoipUpdateRows


(Barry R) #1

I’ve just installed Geoip & I’m having trouble configuring it to apply to previous reports. I have the latest Piwik, 0.5.5, working without problems on a Linux server. I followed the instructions at dev.piwik.org/trac/ticket/45 for downloading & installing Geoip. It works ok for newly generated reports, but the instructions to apply it to previous reports don’t work out for me.

The instructions say to run geoipUpdateRows.php (and by the way, I didn’t need to rename it from *.php.txt, it came as *.php), but as I don’t have command line access to my server I tried to run it via a browser (as suggested by the instructions). I temporarily removed a .htaccess to allow me to do that. When I ran geoipUpdateRows I got the following error message:

Piwik couldn't write to some directories.

Try to Execute the following commands on your Linux server:
chmod 777 PIWIK_USER_PATH/tmp
chmod 777 PIWIK_USER_PATH/tmp/templates_c
chmod 777 PIWIK_USER_PATH/tmp/cache

I changed those directories from 755 to 777 but it made no difference. Anyone have any ideas how to get past this?