GeoIp after upgrade to V 6.1


(Photo Mark) #1

When up grading to V 6.0 of Piwik GeoIP was deactivated as Piwik said this version of the plugin was not compatible with V 6.0. I then up graded to V 6.1 and after that downloaded and installed the latest version of GeoIp from the ticket page. I simply over wrote the plugin files. GeoIP stopped working. I then deleted the GeoIP plugin folder and uploaded again along with the latest map from maxmind. Still not working, anyone with the same problem?

PS - I still can read the past data in GeoIP, so that works.


(pgs) #2

Same here. Tried all the things you tried, too.

Error message:

“Notice: Undefined property: Piwik_ArchiveProcessing_Day::$strDateStart in /home/p235q/public_html/realfragment/piwik/plugins/GeoIP/GeoIP.php on line 147”

regards, pgs


(Matthieu Aubry) #3

in the Piwik 0.6 Geoip compatible plugin (download at http://dev.piwik.org/trac/attachment/ticke…0-%20GeoIP.zip)) there is no strDateStart at line 147 - are you sure yyou uploaded all files correctly?


(Photo Mark) #4

I do not get any error message. Just “no data for this table” in the widget.

The link above to Geo IP did not work, I used the link on this page:dev.piwik.org/trac/ticket/45


(Photo Mark) #5

Hey - I re-downloaded and re-uploaded the Geo IP plugin and it started working again. Go figure. Now I also have the newest IP map.