Gateway Timeout issue on cron:archive task


#1

Hello,
we wanted to setup the archive cron on one of our clients sites but running into the following error when triggering it manually (to test it’s working):

/path/to/matomo/core/Common.php(271): Notice - unserialize(): Error at offset 0 of 246 bytes - Matomo 3.9.1

Error: Error unserializing the following response from ?module=API&method=API.get&idSite=1&period=week&date=last260&format=php&trigger=archivephp: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>504 Gateway Timeout</title> </head><body> <h1>Gateway Timeout</h1> <p>The gateway did not receive a timely response from the upstream server or application.</p> </body></html>

Wondering what might cause this. Couldn’t find a solution to this problem yet. Since it’s not throwing a ‘mysql is gone away’ notice I suppose it might be caused by something else. This install is hosted on a managed hosting so we cannot change the mysql-conf anyway.

Raising execution times (180 sec) and memory limits (512MB) didn’t help either.

ran the command with
PHP 7.2.3 (cli) (built: Mar 5 2018 11:28:44) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.5, Copyright (c) 2002-2018, by ionCube Ltd.

Can you think of possible causes?


#2

I am also getting this error. Any clues?


(Fabian Dellwing) #3

@zitrusblau Are you using nginx with php-fpm or a reverse proxy before your Matomo instance?


#4

Hey, thanks.

The site we’re having this issue is hosted on a managed server (L5) (df.eu). So, Apache as a webserver is used. I’m not a server admin so not sure what is the exact setup here and how to find out. I suppose there’s some kind of reverse proxy being used but not sure. The active PHP module is not FPM/FastCGI.