GA Importer broken?

I set up the Google Importer for another side, months after I run successfully an import in my instance. Now I get errors after about 1 hour after starting:

Error on day 2022-11-30, { "error": { "code": 401, "message": "Request had invalid authentication credentials. Expected OAuth 2 access token, login cookie or other valid authentication credential. See", "errors": [ { "message": "Invalid Credentials", "domain": "global", "reason": "authError", "location": "Authorization", "locationType": "header" } ], "status": "UNAUTHENTICATED" } }

Did the authentication change and times out after a defined running time?
Also - the referenced link ( informs:

Warning: The Google Sign-In JavaScript platform library for Web is set to be deprecated after March 31, 2023. The solutions in this guide are based on this library and therefore also deprecated.

Will the importer plugin then completely stop working - or is there any planned update?

Best Regards

For me works but only with GA3

Have you checked your 0Auth consent screen? How many tokens have you used till this error?

I assume you know that the limit is 10.000 tokens/day

Have you imported GA4 account? Maybe you can help me

The GA3 worked but in GA4 i get this error:

{ “message”: “The value for the ‘name’ field was invalid but must be in format ‘properties/123’.”, “code”: 3, “status”: “INVALID_ARGUMENT”, “details”: [] }

Im ussing the purposed format properties/{propertie number}

I know its 10.000 tokens a day. However the google cloud dashboard for this project seems not to be too detailed and up to date. It often says “no data”.

So the error message might be a signal, that the limit has been reached?

For GA4 you need some more APIs to be connected, as in the documentation. I currently import the old UA.

Yes, i have imported a huge GA3 propertie and i got this same error every day till the end of the imporation.

About GA4 i actually have Analytics Reporting API, Analytics API and Google Analytics API.

Maybe i need another one? Can you link me this documentation? Im not getting a premissions error, im just getting invalid format error.